Cubase MIDI File export adds 1 bar at the end

I’m trying to build my own set of midi files, 4 -8 bar chordal or melodic/seq/arp loops, ready to live preview via media bay so i can use any of these midi parts as building blocks.
As far as i understand is that i can preview only midi files using the current instruments in my arrangement.
Midi loops get only previewed with the original channel strip instrument used in the original session so i had to go with midi files. My problem is that the file has always 1bar extra.

As an practical example: 2 bar sequence, 1 instrument.

  1. create a Event containing a sequence from bar 1 to bar 3 (2 bar loop)
  2. select the desired part containing the sequence
  3. set the locators (Bar 1 -3, 2 bar loop)
  4. go to ->File Menu -> Export -> Midi File
  5. uncheck every box in the dialog

When i select the Midi file it displays always 1 extra bar, in this case a 3 bar grid instead of 2.

Hi,

Length if the exported MIDI File is not based on Locators settings. The whole file is always exported. Make sure, there is no event at 3.1.1.0 at all, please.

Hi Martin,

thx for the fast reply. That did the trick. I had to shorten the last note in the sequence. Now the file has the correct length.