Cubase midi pause and catch-up

I am using Cubase 9.5 on Windows 10 with all the latest drivers. My midi interface is a MOTU Midi Time Piece AV. My Audio interface is a Steinberg MR816csx firewire.

When I use MIDI devices, there is randomly a “pause” of up to a few seconds in the playback of nodes - followed by a “catch-up” mess wherein all the notes that were stacking up during the pause suddenly fire. It is making MIDI instrument use impossible.

I have installed the latest drivers on the PC, for Steinberg and for the MOTU. I looked for a way to “thin out” the midi data, or filter it to only notes, but the problem persists.

Any ideas how to fix?


Could you try to change Buffer Size? Start with increasing the value, please. Also try to disable/enable ASIO Guard.

I disabled ASIO guard, and downloaded the latest driver from Novation Automap for Impulse 49.

After getting very excited that this could be fixed, after several reboots, uninstall, reinstall, my system is now even worse. The Cubase piano roll clicking with the mouse no longer send midi data to VST. Pressing notes on controller no longer trigger VST. I can see blue bar indicating midi data is being received, but MIDI triggering live auditioning of sounds no longer works at all. If I press play and cubase plays MIDI data present in the score, it sounds fine, but I can no longer trigger anything with my MIDI controller, and even Cubase is not behaving as it was before, in that clicking on the piano keys on the side of the piano roll send midi / blue indicator goes off in the track, but no sound, and no midi data is received by my VST nor my external MIDI devices.


Could you try Cubase Safe Start Mode, please?

After working with chat support, what ended up fixing it was to trash Cubase prefs and restart Cubase.