Cubase Mixer and Plug-ins

Hello Everyone,
I’m new to this forum, been a long time user of Cubase SX and just upgraded to Cubase 6 64bit, running in Windows 7 64bit.

I have a couple of questions that hopefully someone can help me with:-

  1. I use a twin monitor system and like to place the sequencer in one monitor and the mixer in the other. But in this new version of Cubase 6 I’ve just bought and installed, the mixer is locked within the sequencer window and wont let me drag it out into the 2nd monitor window. Anyone know how I can unlock the mixer window so that I can drag it into the 2nd monitor??

  2. I use a lot of 32 bit plug-in’s, main one being EZdrummer I use for groove creation. Having just installed EZdrummer again I find that its doesn’t appear in the VST instrument box and fear that this 64 bit version of Cubase cannot use these 32 bit plug-ins. Is this true and if so are there any work arounds??

Thanks in advance for your advice/help.

Shane

Hi,
If you set your mixer winder to “Always on top”, I believe it will let you drag it out of the Cubase window.
Some of the 32 bit plugs have been reported as not working well with the built in BitBridge. I don’t know about EZ Drummer. I use Jamstix and if I put the .dll in the common VST folder with other stuff, it did not work (I don’t know why but a guess would be that if it finds something in that folder that causes a problem, it just ignores the entire folder). I put the .dll in its own folder and set a path in the plug-in information in Cubase and it works. If that doesn’t do it, you could try the free trial of jBridge (just google it).
HTH
J.L.

I actually bought jBridge before I bought Cubase 6 to prepare for the 64-bit rollover. So I can attest that it works pretty good for a lot of my 32-bit plugins but some don’t work like they used to in Cubase SX when I used it and some even crash but I guess having two bridges is better than one. jBridge tends to work anyway usually where BitBridge fails me.

Download the latest version: EZdrummer 1.3 is 64 bit.

If you don’t see other 32 bit VSTs appear in the list: check in Devices -> Plugin Information whether Cubase reads the 32 bit applications path “C:\Program Files (x86)” too.

Thank you everyone, I confirm that setting the Mixer to always on top allows it to be dragged into the 2nd monitor.

The 32bit to 64bit bridge issue I’m working on. Thanks for all your advice.

Shane

That’s very buggy behaviour, having to set this, don’t you think?

That’s not buggy, it’s just a bit unclear going by the amount of people asking this question on here. As far as I can see it works as intended.

You mean that it’s intentional that the Mixer has to be on top before it can be moved to another monitor? Maybe I’m missing something but it doesn’t make sense to me.

Most of the applications I have seen like Word, Excel, etc., by default child windows are confined to the limits of the application window. I have seen some where you are able to “undock” the child window and take it outside the limits of the application window, which is what is happening here when “always on top” is selected. I think it works normally but maybe the terminology would be more clear if it said “undock”?
J.L.

Yes. If you expand the workspace over the 2 monitors you don’t have to use always on top. Like Jaslan said, many programs confine their child windows to the parent application window space, Cubase does the same.

Ah, I thought you were extending the app window to the full width of the two monitors. In fact, you’re moving the mixer to beyond the normal boundary as set up for a single monitor?

https://www.steinberg.net/en/support/knowledgebase_new/show_details/kb_show/multiple-monitor-support-with-steinberg-products/kb_back/2025.html?tx_p77sbknowledgebase_pi1[keyword_search]=Multiple%20Monitor%20Support

This here. Sounds like you were maximizing the window then finding you couldn’t place the mixer on the second monitor without using “Always on top”. If you instead simply stretch the main Cubase window across to your second monitor, then size the project window to fit the first monitor, you can then move your mixer to the other screen. I do this too. The problem with using “Always on top” is if you click accidentally on the windows background it hides your mixers (well anything set to always on top) till you click the main window again. it becomes a nuisance.


Rev.