Cubase Newbie Troubles

Hello All:

I’m just coming over to Cubase 9.5 Pro from the now-defunct Sonar.

I’ve installed Cubase and have it set up enough to get sound out of it. My audio interface is the USB version of the RME Fireface UFX.

However, when I place an audio loop onto a track, the loop will not play correctly. Even with the Fireface UFX buffer set to the highest setting (2048 samples) I experience glitches when trying to play the loop. If I set the buffer to 512 samples the loop won’t play at all, and if I then press F12 the 2 bars at the top of the meter (but mostly the Real-Time Peak) intermittently peak into the red, even when I am not trying to play the loop. [u]The program is just sitting there doing nothing, and I am seeing peaks into the red on the Audio Performance meter.
The Fireface UFX has always worked perfectly in Sonar, and still does. I’ve uninstalled the Fireface UFX driver, re-installed it using the latest version, and updated the firmware. Again, it works fine in Sonar.

I called Cubase tech support, who said that it was a Fireface UFX issue, and advised me to call RME, which I did. RME’s very reasonable take on this is “If it’s a Fireface UFX problem, then why is it working just fine in Sonar?” I called Cubase TS again yesterday but they told me the case was closed. When I insisted, they said someone would call me back, but so far that has not happened.

My computer is a Creation Station CS450v3, with an Intel Xeon CPU running at 3.50 GHz; 16GB Ram; 64-bit. I’m on the latest update of Windows 10.

Any help would be most appreciated. Maybe it’s just a simple Cubase newbie mistake. Thank you.

You are sure you have selected the rme driver and not the generic one in Cubase ?

Hello and welcome.

Sounds more like a general performance issue with Cubase than the audio driver.

Your PC should be the one from Sweetwater, is it?
If yes, it looks like it already comes with optimized BIOS (as per this link: What are the BIOS Changes for the CS450v3? | Sweetwater), but you might want to check that your settings actually match the changes listed there - the first 5 entries are usually key to good real-time performance (note that these should be ‘Disabled’ as listed in the changes).

Before checking the BIOS, you might want to have a look at the Power Options as well. Please make sure you are using a High Performance power plan and verify that the advanced power settings (Power Options → Change Power plan settings → Change advanced power settings) are set this way:
Hard disc → Turn off hard disk after → Never
USB settings → USB selective suspend → Disabled

Also, please try to play back with ASIO Guard enabled and disabled in Studio → Studio Setup → VST Audio System (two different test runs).
You can also set the Audio Priority to ‘Boost’ and see if that makes a difference.

I would recommend to check out the GPU driver installation as well - we recommend to select the custom installation mode and only install the video driver, with no gaming components added (valid for both nVidia and AMD).
These components often cause issues with thread prioritization.

We have an article that relates to all of this, please check it out:

I couldn’t find which CPU your system is using, but if it is a XEON with many cores, please be aware of this issue:

Further to that, thread synchronization can still be a problem on some systems, you may want to test with hyperthreading disabled and see if it actually makes a difference.

It could also be a conflicting device or startup item, but that’s easy (although it might take some time) to check by disabling (not uninstalling) one device at a time and / or disable startup programs using msconfig.

I hope this helps a little.

Thanks to both of you for your attempts to assist me with this problem.

It turned out to be Avast Antivirus. When I disabled it (Sweetwater Tech Support’s idea), Cubase started working as it should.

So I’ve uninstalled Avast, and have started using Windows Defender, which apparently plays nice with Cubase.


Thanks again.

Thanks for the follow-up!
We had some users who had the same issue with Defender, so it looks one of those annoying system-specific problems (I’m personally using Defender only on my DAW since 2010, I frankly never had to disable it).
Sometimes backup or encryption can cause similar issues, too… anyhow, always interesting to hear how things get solved.