Cubase no longer converts sample rate to project settings on import(?)

When importing files, Cubase asks to convert files to project settings if need be - it used to be that files would be converted according to project settings, including sample rate. Now this no longer seems to be the case - I get the same dialog but files are not converted. This caught me out & I ended up mixing a song at the wrong speed. doh. Anybody any idea where can I switch this back on? I realise I can convert in pool - but would much prefer to convert on import. Thanks.

Hi,

What Cubase version exactly do you have, please?

As far as I remember, there was this issue if you have imported more than 1 Audio files at once. Then only the 1st one has been converted, no the others. But this issue has been fixed in one of the Cubase 10.5 updates. Definitely it should work with the latest Cubase 10.5.20.

Is this the case on your side, please?

Are you you importing from CD, or a file from your conputer?

I was importing multiple mono 48k audio files from a folder. Cubase version10.5.12

I have frequently & successfully seen multiple files converted to project settings on import (via pool command) - for years in fact!