Cubase Noise on Export Audio / Noise floor Issues

Hei Grada - I tried with it on and off, Asio Guard on and off, and still the same.

Ok did you tried to set ASIO driver to No Driver and perform export ? Did you try to check exported wav from Cubase in different host? Also remove SPAN when you do test since I had the same issue (I think it was version 5 or 6) when multi processing is on. I was able to find link between Voxengo plugins and when multi proc is on. But It gets solved with VST3 versions.

With “No Driver” the export produced the same glitch. With Span off the track that was exported, same glitch.

I tried to reproduce it as you suggested but cannot get artifacts you mentioned. Can you send me that test file?
If I get you right

  1. Put retrologue in empty project as instrument track without any midi sound
  2. Add decapitator/Saturn on insert of that instrument track
  3. Set some range/Export audio mix down 24bit wav/Import exported wav
  4. Voxengo Span (Range Lo parameter set to -180) should display artifact

Almost - you also need to add some midi recording in. See my graphic below.

Thanks for the feedback.

Indeed there is something strange happens how Cubase handles 3rd party plugins and unfortunately I can confirm this bug.
Since I experience this and other similar quirks from time to time noticing strange behavior on my RME digicheck, and intrigued by OP post I took some time to investigate this further and made some tests.
Tested and confirmed on 3 PC workstation (hope some mac guys can test it too) w/without Asioguard/Multi Thread processing/both 32 & 64bit mix engines w/without ASIO driver etc with Cubase8,8.5,9.

***** These are some 3d party plugins with which artifacts happens that I tested: FF ProQ2, Saturn (probably all fabfilter are affected) ,u-he Uhbik plugins (probably all u-he plugins are affected) and Acon digital Multiplay which is free. Certainly there are more 3d party VSTs that in combination with Cubase making those artifacts.

Here are the steps:
1. Create new project and add 3 groups
2. Add on each group one of the VSTs that are affected (see above)…for example 3 FF Pro-Q2 one on each group.
3. Select range and export mixdown on 24bit or 32bit
4. Import it and apply normalization to the imported file.

For the purpose of test I put free VST Multiplay you can find it here (in case you don’t have some of commercial plugins mentioned) and to rule out any self noise producing in VST I Bypass all 3 instances. Please see in gif I attached.

Exported audio (not normalized) has peak on -138dbfs which isn’t true 24 bit anymore and in compare with Reaper 5 where this doesn’t happens with any of these plugins I consider this as flaw.

As OP described I follow his steps and made screenshots bellow:
C9.5 Decapitator:
Rea5 Decapitator:
C9.5 Saturn:
Rea5 Saturn:

Although reproducing steps are easy I put Test Projects with ProQ2 or Multiplay just in case


1 Like

Thanks for the confirmation of the issue and the demo.

I can confirm these issues do NOT happen in similar tests in Sonar and Studio One.

I am having the same issue with some waves plugins.
( mercury bundle )
It’s always, it’s something that introduces noise/ harmonics / distortion.
I have all the waves noise / analog switches off.

I notice it when I come to a quiet section of the song.

Annoying but , If I find the culprit, disable it and re enable it.
Problem gone.

Waves in attempt to emulate hardware emits a brown/pink/white noise and colors the sound with harmonics etc which is fine.
Here we have totally different thing, and speaking of plugins that are totally transparent (at least in repaer and some other DAWs that OP tested)

This bug happens when plugins are BYPASSED if you stay on the gif for a minute you will see what we are talking about.

I had something similar happen, after turning off most plugins, I finally found that iZotope Ozone introduced the noise.
Turned it off and on again, and the noise was gone.
Any chance you got Ozone on your master bus ?

I can confirm the noise with Multiply. Even if I disabel/reenable the plugin. Its the same squarish noise like in the screenshots above.

I also tried to change the processing precision from 64 to 32bit- same noise

Its very low but still not good.

Same result here, even with only 3 audio tracks, with different bypassed plugins, my thought is that in that case, the principal culprit is the Normalize process… It’s like sometimes there a sort of dithering, that result even with 3 bypassed Waves Audiotrack plugins on 3 audio tracks is not a full null file. There is a bit of random, due to floating point calculations…
When playing the result file ( without Normalize ), you can hear nothing, the meter don’t move at all, even if you an L2 maxed out, no signal, full silence…
And yes the problem is the Normalize process… basically it will take a file, then find the max value, calculate the difference between this max value and the 0Db FS, then add the resulting Dbs to the source. I have forgotten a lot of detail, but the floating-point computer arithmetic have a rounding system, it’s impossible to do without this approximation ( btw 64 bit engine approximation will be far smaller than 32 bit engine ), if the effect plugin have a sort of oversampling, it will had even more “small errors”, and the mixing engine will not give only 0 but the smallest step over or under 0. And if you normalize that kind of file, the result is… ultra magnified errors ^^ Cubase don’t tell the Db it add to put those file at 0Db, but i bet it’s something like 106Db or more, a ridiculous amplification finally :slight_smile:
Don’t focus too much on that, you can estimate that the result of this strange behavior is totally inaudible :wink: Or if it really bother you, you can put a gate somewhere, so this micro level noise, will be muted ^^

But for the original post, a noise that appear only when exporting… never seen something like that in my life in all the DAW i’ve tested :confused: maybe a problem with the plugin live mode and rendering state… very strange. Oh yes sometimes some plugs offer different settings for live mode and rendering mode… it can be a possible cause… maybe a weird oversampling setting somewhere :confused: you can try to export each track, to find the place where the culprit is, by deduction :wink:

Thanks for confirming guys really appreciated.

I think gif is pretty self explanatory, so no Ozone or other plugins are involved.

We are in digital domain, so this must not happen! With this bug theoretically we are not in 24bit anymore… I first notice this several years ago when I saw same noisefloor on my RME digicheck. Examining further (lot of testing and comparing) I got mentioned results. The same bounced Cubase file normalized in different program will result same artifacts (normalization works fine In Cubase if you pointing on that). “Normalize” is there just to show error that others may not be aware of.

My fav gate is FF pro-G which will certainly lead to the same artifacts :smiley: but nice try.

Just again to summarize: This is not happening cause plugin behavior that some others claimed, this probably happening how Cubase handles some of 3rd party plugins cause other DAWs confirmed that ProQ2 or Multiplay etc are clean and noise floor free, so this exclude all analog-modeling/dithering/self oscillating and other similar things some guys mentioned. I just take Multiply for test purpose as a free plugin.

In 15 years working with Cubase I stumbled on all various glitches/quirks and stuff similar like this (some are so bizarre that probably I am the only one who encounter on them) and I am trying my best to test and describe problem in detail (as you can see from my Null Bug Test in my signature)
I really don’t know why is this happening maybe some of the devs can tell us something more? Also can some mac guys confirm this too?

Yes after some tests, it appear that the crazy “normalized” file, have a DC offset, and to make it goes all the way to 0dB you have to amplify it between 144 and 145dB… so it seems to be a very low noise floor. And maybe it represent the total and disposable dynamic of a 32bit audio file… not really sure about this one…

Coming back to this issue as the OP. I’ve been testing quite a bit on Studio One 3, and not getting these issues at all. From the feedback of users who have tested it, it seems to be that its an issue for all Cubase users, but most of the time nobody notices because it is such low level and in most cases inaudible.

So …

  1. Why would this happen in Cubase, but not another DAW with same settings/plugins?
  2. Is it necessarily a bad thing, if the levels if these artifaccts are so low - can it actually affect the quality of final output when mastered?

At these levels no, it’s not a huge deal. 24 bit dithering adds louder noise, and your samples (and maybe even some synths) likely have a higher noise floor than that.

It’s definitely still something that should be looked into, but I wouldn’t lose sleep over it.

Although even 16bit dithering is discussable subject whether use it or not. 24bit dithering is even more discussable.
Of course this bug probably wont stop anyone using Cubase. Imho it better to be solved when its small, cause from practice point of view this could lead to some other problems and make some things unreliable in future which was happened before.

Coming back to this issue - its really doing my head to know that artifacts are being added, and I do not know WHY so I can still have the chance to prevent it …

So back to my earlier question : Why would this happen in Cubase, but not another DAW with same settings/plugins?

And if anyone can put forward a suggestion as to WHY this might happen so I can prevent it occuring in the future.

Just did a little testing with this. It seems not only to be related to the export function.
Basically i created 2 group tracks, on one i loaded Decapitator and on the second i loaded Fabfilter Saturn and then on the master bus i loaded Fabfilter Pro-L2.
Now if both plugins on the group tracks are disabled, Pro-L2 shows -INF at the peak level meter but at soon as I enable one of the plugin it will show -167Db in the peak meter of Pro-L2.