Cubase not receiving MIDI events from Groove Agent drum pattern.

Apologies for posting this again but I made a mess of the title of my previous post and I think people answered a question I hadn’t posed!

I have been trying to record a demo, starting with a drum track, using Groove Agent SE4 on Cubase Artist 9. Please note that I have adopted this approach at least twenty times in the past with no problems.

Here are the steps.

  1. Create an empty project.
  2. Add an instrument track (Groove Agent SE4) and select a kit. Choose the required pattern.
  3. Enable record on the track
  4. Click record on the Transport and get a couple of bars of metronome intro.
  5. The drum track pattern then starts playing. I can hear it and the signal is showing in the mix console. HOWEVER, no MIDI events are showing in the MIDI editor nor are any being recorded.
  6. If I manually trigger the drum sounds from a MIDI keyboard the MIDI events are showing and are recorded.

So why does the Groove Agent pattern not trigger the MIDI when the keyboard triggers it? I’ve done this operation a few times successfully and I’m not aware of making any changes to the configuration of my setup (though I have been forced to install the latest Windows update.)

No, I think I answered the question you posed and the answer is still the same. You need to have the correct MIDI input set up in the track that you want to record to, ie: the Groove Agent SE MIDI Output. Without that setup it will not record the MIDI from Groove Agent. If you have succeeded twenty times in the past then you have previously had the MIDI input setup correctly. If it is currently set-up as I outlined and it’s still not working then there is another issue.

If you just want the pattern on the timeline the easiest way to get it there is drag midi to host…otherwise you need to set up input routing as planarchist says. You can have the GA output as input on the SAME track if you want.

Thank you for your responses. What baffles me is that I have been following exactly the same default route, with the very few operation items as outliked above, and suddenly the routing is wrong. When I return home I’ll try and will report back, but thanks again for your help in this matter.

Have you selected MIDI port B for pattern pads? If so, you need to use the appropriate port when routing the MIDI. Perhaps posting a screenshot showing your routing would help.
BTW, it is still not too late to delete :wink: one of the three topics you have posted on this question (the one with no replies).