Cubase not recognising 'save' status.?

This problem is not new; been there since v10.5 or so IIRC. Just getting stuff off my chest…

  1. Left a project opened, untouched for an hour or so.
  2. Came back, had a listen. I made a couple of tweaks, saved my work.
  3. Decided I wanted to move on with something else entirely, so immediately did a File->Close but was prompted with the ‘Save, Don’t Save, Cancel’ dialog.

Weird. Maybe I didn’t save properly… Usually the project would just close.

  1. So to be sure, I pressed ‘Cancel’ at the prompt, made another small tweak in the project and saved again. Immediately went to ‘Close’ the project and again the prompt popped up.!

I was annoyed now; the program seemed stuck in a loop. It wasn’t seeing my ‘save’ command. So I ‘Saved’ from the pop-up prompt and the project saved and closed.

I shut down Cubase and re-launched. Worked on a different project. Without any lunch breaks this time I tweaked, I saved, I could close straight after - and no problem prompts…! Hurrah.!

Today, I worked on that most recent project again; this time left it open for well over half an hour, whilst seeing to other chores. Came back to it, tweaked around a bit, saved it and immediately went to close it. Up popped the annoying prompt.!

And just as before, from here the program wouldn’t recognise any incremental ‘saves’ until I acknowledged a ‘Save’ or ‘Don’t Save’ from the pop-up prompt.

The computer did not go in to any ‘sleep’ mode, in between tweaking the projects. The behaviour was seen with other projects, if they’d been left for a period of inactivity…

Anyone else.?

No harm had come to any project involved in the making of this report.

This happens with some plug-ins that have modulation which is constantly running even in the background when the Project is stopped and not playing.

While you are not changing the Project and causing it to prompt to Save, there is a bit of hardworking code that never takes time off and is constantly changing the Project that does cause the prompt.

You can ignore it if you’re comfortable with what you know you’ve saved, or save it when prompted. No need to be concerned about it though.

Oh… Ok, interesting info @raino - thanks.

That seems a good explanation for any first attempt at a ‘Save’ after inactivity, but, I did then deliberately go and re-tweak the project, perform a ‘Save’, tried to do an immediate ‘Close’ but yet still get the prompt… The program seems stuck in that ‘mode’ and I can’t get out of it.

However, normal working without leaving things alone for a spell and I do a ‘Save’ then an immediate ‘Close’, there’s never any problem prompt.

And no, not any big deal - and it seems so far, no-one else is seeing/reporting the same behaviour… Maybe just me…!

I’ll take another look at some point, with a ‘no inserts’ project etc… see if I can further nail things down.

No its not just you, this has been brought up several times over the years on the forum. I’ve got a couple of pretty recent Projects this happens with.

If a plug-in is constantly changing a value then any time that passes, even if only fractions of a second long, will cause the prompt. “Immediate” isn’t quite fast enough in this situation.

Understood - I posted because I only seemed to see the behaviour after a period of inactivity on a project; for me, it isn’t after every “Save/Close” operation. Which kind of conflicts with your last paragraph…

But anyway, you’ve given me ideas to chase; appreciated. I’ll do some more digging…