Cubase Not Recording MIDI

I opened a new blank song, added an instrument track and selected a Halion Sonic pad which plays perfectly in the Halion window and on my keyboard controller.

With Rec enabled, I press Rec on the transport and there starts the problem. No sound from MIDI kybd and no MIDI recorded into the track. Halion kybd has sound but nothing records to track. Baffling. I’ve been trying to fix this for the past two hours.

This behavior is identical in Cubase Pro 12 and 13. I’ve checked every setting I know and rebooted my PC twice.

Could someone kindly help? Thanks.

Is MIDI getting recorded if you use just a blank MIDI Track?
In other words, does the usage of Halion Sonic play any part in the problem at all?

Furthermore: open the Preferences dialog, go to MIDI → MIDI Filter and uncheck any options in the Record section.

1 Like

Thanks JM. On a blank midi track, no keyboard activity is registered. As for midi filters, I examined the midi drop down menu and didn’t see a midi filter menu. I looked around for midi filters and couldn’t see any although I do remember seeing midi filters on the left sidebar from time to time.

I checked with Google Gemini and its suggestion worked:

MIDI Settings:

  • MIDI Filters: Go to Preferences → MIDI → MIDI Filter. Disable any filters in the Record section.
  • Input Transformer: Make sure you don’t have any Input Transformers active that might be altering MIDI data.

It’s times like these I really wish the devs at Cubase bothered to create some form of simple mode for setup and checking of such things. I’m hoping someday they come up with a quick reference visual object oriented interactive event status chain. Something a person could look at quickly to determine whether signals are getting through and how they’re getting through or not, then fix then straight away.

Cubase can be amazing but sometimes it’s a real PITA. :grimacing::confused::face_vomiting:

Far too many technical things to remember for an artist who just wants to get to work.