Cubase play sounds earlier then they are

Strange issue, sounds are played earlier then they are. When I put the cursor on the very beginning of a sample, I hear only its tail, and to hear the whole sound- i need to put the cursor about half a bar before it.
I noticed that the problem dissapears for several minutes when I change latency; but then it come back again.
Also I can reload the project, but still after several minutes
sounds are not playing properly.

P.S. I have Ur22 mk2, everything is ok with the drivers and usb port


Do you mean an Audio samples/files?

Make sure, there is no Track Delay setup on the track, please.

Yes, I mean audio files. Of course there is no delay on the tracks. After all, it always stars after several minutes working in project, seems to be a bug.

I attache image to explain concretely what I mean. On the picture sample stand at line 104. And I can hear it only when I hit the play from 103.4. When I hit the play from 104- i hear only tail. And this goes on with every sample, sound, midis, whatever.

Im sure its a bug because it dissapers for several minutes when I change the latency on audio card. If you have any idea, please help me, its just impossible to work with such problem… By the way, I changed usb cable of audio device, tried latest driver versions, tried another usb port… nothing works :cry:


The picture is missing. Could you attach it, please?

I can confirm this bug but in my case music plays later then cursor actually is. Changing audio driver to ASIO for All fix the issue.