Cubase plugin midi button issue

I put this in here because I don’t think it’s a bug, but more on my end when setting up my controllers.

I’ve been a Cubase user for several years since Cubase Elements 6. I use a lot of midi controllers to help me play the music I’ve written.

However I have one slight issue, and it’s with using midi buttons. Whenever I try to use midi buttons instead of faders to control my plugins like delays, reverbs, etc, there’s always a slight playback issue when I press it. Note that I am using the bypass button and not the on/off button. It’s hard to describe, but in terms of using the delay plugin, when I deactivate the bypass button, it finishes the previous note before effecting the next note of my track. Does that make sense? It never sounds good when I bypass it. Especially on snare drum tracks, when I need a snare roll(use a plugin instead of doing the roll by hand, in 1/16), you hear the previous note played on top of the current note, and it always throws me off of my rhythm.

Anybody getting me? I like using buttons instead of controlling the mix setting by hand because it doesn’t require finger accuracy and I can use another knob at the same time sometimes.

I have a feeling it’s on me because it’s been doing this ever since I’ve started using the Cubase plugins(which are very good), and it throws me off of my rhythm. I would like to play live sometime however the audience can’t hear this playback issue when I use midi buttons. The plugins need to be activated cleanly every time I use them for me to be able to use them effectively.

In device setup, I use the generic remote, and midi buttons assigned as “controller”(or whatever the default is) because that is the default for all my midi controllers. I also use the R flag, along with I believe, the toggle flag, one of those flags in the bottom half of the window.

Thanks for the help, I appreciate it.


Do I understand you correct, you are using common Inserts plug-ins on your Audio tracks, and you control Insert plug-in bypass from MIDI via Generic Remote Device setup. Am I right?

a fader / knob / wheel is a “continuous controller” which sends a “stream” of continuous data
a button /switch / key is an “incremental/decremental controller” which sends a “single” data change
perhaps you can program the buttons to send continuous incrementing / decremementing data
no idea how though i use mackie control which is all preprogrammed


Switch could also send dedicated values, like 0/127. Not inc/dec only.

Correct. I don’t use too many third-party plugins, just the default cubase plugins. And actually, it happens with all plugins, not just the standard plugins.

I use basically default midi mapping settings, nothing too fancy. Don’t have a lot of midi knowledge, so basic stuff gets the job done for me.

i agree but it only sends one data set per “push” eg “0 or 127” not 0 to 127" like a wheel/fader/knob can. i guess its inherent in the device itself a switch is normally on or off and a push changes state “once”. a fader, wheel, or knob is generally an analog potentiometer that is scanned or otherwise converted to digital data with varying degrees of resolution. i suspect thats where the OP is experiencing a “delay” between switch pushes. im not sure but i dont think holding down the button will achieve a continuous data change unless it is programmed that way specifically and can physically function in that way.


Actually, I had similar experience few days ago. I didn’t investigate more, but I was thinking that it could be related to the Automatic Delay Compensation.

Edited: Oh no, it was WaveLab!

The Automatic Delay Compensation has to be solved for this scenario in Cubase.