Cubase Pro 10.5 Hangs on Close X Button (50% of time)

I’d say that 50% of the time that I quit Cubase Pro 10.5 using the red X button in top right, it does NOT quit the program.
It seems to hang… however the windows 10 Task Manager does not indicate it as not responsive.
Regardless, it doesn’t go anywhere so I end up quitting using the Task Manager when the X button doesn’t work.



You could use Microsoft ProcDump utility to make a *.dmo file of the hang. So we would see which process is hanging.


could you try to add an audio file to a project, copy it via CTRL-C ( no need to paste anywhere ) and close cubase, please ?
Does it happen in this case 100% of the time ?
Thank you.

Check that you don’t have any old Rewire.dll file on your system. Trashing it was how I fixed a problem similar as yours.

I’m currently trying the simplest suggestion here (from Jorge) since he solved the problem on his end.

I found a Rewire.dll in 2 locations:
C:\Program Files\Common Files\Propellerhead Software\ReWire

I don’t even know why I have any Rewire files on my system. Where do those come from? Are they still necessary or obsolete?
Deleted them for testing purposes… and so far seems to be working.


ReWire files are necessary, if you want to connect two ReWire applications and sync them. For example Cubase and Ableton Live or Cubase and Reason…

OK, but I can confirm that the solution proposed with deleting these files has indeed worked, and it quits very fast too when I click the X now.