Cubase Pro 10: Pitch Shift by Time Stretching not working

Hello I have been using Cubase Pro 9.5.30 and Pitch Shift by Time Stretching works great here.
In new update Cubase Pro 10 this function doesn’t work, I mean just nothing happens when i choose “Apply”.
Let me clarify right away: I know that Pitch Shifting with “Time Correction” works fine in Cubase 10, but I’m interested in changing the pitch by stretching the audio (when Time Correction is off).
In Cubase Pro 9.5 it works, in Cubase Pro 10 it doesn’t work.
My operation system: macOS High Sierra 10.13.6.
Also I record video of this problem, may be it will makes my problem be more understandable:

If someone know how to solve it by using of Cubase Settings please explain me, how to do it exactly, if it’s bug of new version and can’t be solved by user, would be great if Steinberg guys will see this topic and fix this bug…
Changing the pitch of audio one of the most important process in music production, I’m sure that many other producers will agree with me.

Also Steinberg removed the volume and the ability to scroll through the audio file in the Import Audio dialogue box, one question: Why?

Thanks in advance.

same problem , i already uninstalled cubase 9 and cant produce now which is sad.

Confirming that!!
Pitch Shift in audio clips -1, -2, -3, … is not working as expected!
Even the function appears (!) in the DOP window!

Only +1, +2…+12… working!!
I hope you don’t let this bug like Cubase 9.5,
that took one year to fix the DOP… OMG!!

Here goes again!!!



Same problem here :frowning:

Just to add to the voices…same here.

With a time correction algorithm turned on, pitch shifting seems to work fine. With Time correction off…I just get a “processing failed” mark in the dop window.
I didn’t realise how much I actually used that stuff, until it’s now super broken :wink:

Same nonsense happens with pitch envelope mode too.

+1!!! The same problem! Hey, guys, don’t forget - you can use reserve option: right click - create sampler track. From Russia with love.

This explains my confusion the other day. I hadn’t done it in a while and was sure it worked but wasn’t.

+1 over here! :unamused:

This DOP version works fine with Time Correction on, but the traditional Pitch Shifting process won’t work,an exclamation mark appears instead and it wont process anything, not in the transpose section, nor the envelope section… Not to mention they took off useful things, like the pre/post fade in DOP, or even refreshing the process when adjusting the TAIL LENGTH automatically, without having to delete/reprocess…

I really love Cubase, for years, I buy EVERY update the first day it is released (not the best idea). I don’t want to be ungrateful, but c’mon Steinberg, spend less time updating Halion content and poop, and get all hands on deck for the C10 bugs we encounter everyday, not to mention the OLD ONES, like “MUTE PRE-SEND WHEN MUTE” checkbox bug (In PREFERENCES/VST, the checkbox state won’t save with the project) that has been there FOR YEARS. Are resources missing (Should we spend more money)? Or is it just a really bad habit to prioritize fixing the wrong things?

If you want to add value to this delicious piece of software, get it right for your loyal customers, before making it more flashy to new ones… :mrgreen:

Expecting the 10.1 update, hopefully soon…

Windows 7 Ultimate, Cubase 10.0.5, Intel i5 4750, Nvidia GTX 750ti.

After having updated to Cubase 10.0.10 Timestretch still doesn’t work from Menu - Audio - Processes - Time stretch. Nor does Normalize or Pitch shift work. I haven’t tried the other processes. Is it just a bug that will be fixed or am I missing something, should this be done in another way than in Cubase 9,5?


  1. Where is common simple pitch shift? Why I can’t pitchshift audio with no algorithm of time correction in cubase 10? What have I do to pith shift for 32 semitones (for example) with no timecorrection? Why it’s impossible? I takes just 1 click in abletone! And I use that type of pitchshifting very often in sound design. That pisses me off…

You have to uncheck the time correction box in offline processing. F7, PITCH SHIFT. Now you can shift the sample up and down in that window

It would be nice if…
Changing Transpose number in the Info line, when Musical Mode isn’t activated, this nudged the sample without using time correction. The sample would get larger or smaller depending.

In preferences, editing audio, we get a few settings related to time correction. Nothing for the transpose though. The transpose seems to use what ever algo shows in the info line, even though musical mode isn’t active.

This would be a good feature request. I’ll make one, please support it.

If anybody is wishes to expand on this subject, why it is the way it is etc, things we’re overlooking, it would be appreciated.

Here’s the link to the feature request. Info Line Transpose ALGO FREE - Cubase - Steinberg Forums

Apparently, they still haven’t managed to fix this issue…

has all this been fixed in C11 and the time Stretch tool now working correctly when preferences set to realtime, using actual real time not the tape elastique.