Cubase Pro 10 won't Launch after Windows 1903 update


Cubase Pro 10 will not launch on my Windows Pro 10 laptop. I have used Cubase Pro 10 on this machine in the past with no issues. I believe Windows 10 Pro was updated the other day to version 1903. I have uninstalled and reinstalled Cubase Pro 10, and uninstalled and reinstalled the latest elicense software and nothing is helping. I have also tried to run Cubase Pro 10 as admin. When I mean nothing happens, it doesn’t even get to the opening screen. Once I click “Yes” to allowing cubase10.exe to run, nothing happens. Elicense Manager is seeing my USB and harddrive license fine. Not sure what else to do.

Any help is greatly appreciated.

try to reinstall the last vcredist_x64 package on microsoft website

Thank you. Unfortunately, this didn’t solve the issue. Still won’t boot at all.

Have you tried reinstalling the soundcard drivers?

I had the same problem after updating W10 to version 1903, my Cubase Pro 10 didn´t start. But after uninstalling and reinstalling of the soundcard drivers it works again.