Cubase Pro 11 Trial Fails to Start

When I try to start the license period for my Cubase Pro 11 Trial its fails. I get the error message ‘An error occurred which prevented the operation from succeeding’.
‘Starting of license usage period failed’
The USB-eLicenser has other licenses on it such as Cubase Elements 10.5 and works fine allows Cubase Elements to start.


Make sure you have the latest eLCC update installed, please. I would also try to reinstall eLCC as administrator. If this doesn’t help, I would try to start eLCC as Administrator and trigger Maintenance.

I tried all of that and it still does not work.

are you sure, you are using USB-eLicenser, please? By default, Cubase Elements license sits on the Soft-eLicenser.

I definitely have a Cubase elements license on this specific usb-elicenser. I also have Dorico SE on this usb-elicenser.


My problem has now been solved.

I purchased a new USB-eLicenser and transferred the Cubase Pro 11 trial license to the new dongle. I was able to successful start the trial period.

The issue appears to have been with my old USB-eLicenser.