Cubase Pro 11 with Avid S3 via EuCon constantly crashing

I’m using my Avid S3 control surface with Cubase Pro 11 and it crashes when doing certain things like removing plugins and inserting a new plugin in the same insert slot, or it crashes when I close the project to open another one. Another thing is that Cubase doesn’t work if I update to the latest 11.0.41, it crashes so I stayed in version 11.0.30. I wonder if anyone else have experienced this? and if their is a solution.

Angel Serrano “Xerran” @xerranmusic

I use the Avid Artist mix, and I assume the S3 uses Eucontrol too. If that is the case, every time I encountered this kind of issues the only thing that fixed them was making sure everything was at the latest version (including the firmware of the controller). If this doesn’t fix the issue usually it’s a matter of waiting that either Cubase or Avid fix what they need to. As for me and the artist mix I’m currently not having any bugs with both the last version of Eucontrol and Cubase. Hope it helps somehow

Yes, my firmware versions are up to date. This have to be an issue with the Avid S3 compatibility.

I just updated EUCON to latest version, after iPad app didn’t work anymore with Econ. Since that, Cubase 11 crashes instantly while starting with most of the projects. Tried to load an empty project and after that the others in parallel, this works, but needs long time to open. Crashes during some operations, too. So: similar problem :frowning:

I`m on Cubase 11 Pro on Mac / Avid S3


The new EuControl app for iPad works great for me in a newer iPad version. I used to have an iPad 2 and can’t use it any longer, not compatible. You should upgrade to a newer iPad and it will work just fine. In the other hand the compatibility between Cubase Pro 11 and Avid S3 is still a big issue for me cause I mix 100% with the Avid S3.
You can find me on Instagram if anything @xerranmusic

Thought I’d chime in, I tried the Avid Ipad app a while ago and, although very powerful was quite buggy and would cause Cubase to crash a lot. The new version of Eucon Control and new Ipad app (Ipad Air 2) works flawlessly now.