Cubase pro 8.5 cpu issue

Dear users, steinberg,

I have nearly given up on Cubase although I have tried close to everything to make it work. I ve been using Cubase for the last 5 years, in the beginning with version 6 and recently upgraded to pro 8.5 when I bought the UR 824 interface. The problems concerning high cpu peaks, cracks,pops etc are not new. In fact, searching around for solutions I have come accross dozens of people with the same issues i.e a abnormal high cpu usage that peaks in red zone with all the undesirable effects.

I have a powerfull system with more then enough RAM (16gb) and whatever other tech specs to make for an easy functioning of Cubase…but it doesn t…even when I create as little as 8 audio tracks and a couple of instrument tracks and insert 1 plugin here and there the cpu usage blows up. When looking at the task manager and cpu usage there, there seems to be no problem, cpu usage is only a couple %…

This morning I tried the ultimate test : I deleted all preference files, switched of all malware although the pc is not hooked up on the net. Created a template with 8 audio tracks and 2 instrument tracks, I inserted EZ mix2 as a plugin on the audio tracks and EZ Keys plus EZ drummer on the vst instrument tracks. Record enabled all tracks and away we go, cpu peaks all the way into red without me doing anything, vst performance meter very unstable and whipping up and down. So preference files and virusscanners are not the cause.

I then installed Reaper to see if I would get the same outcome. Did exactly the same test using the same tracks and…stable as hell, cpu usage of 1 %, the meters don t even move.

I have one option left. And that is to uninstall everything and install it again. I ve invested a lot of time and money on steinbergs hard and software and I cannot get it to work…although I love the graphics and functionalities of cubase I will be forced to swith to another DAW as I cannot even record any decent work anymore. Clearly this is not my preferred option…

So , there you go,my final plea for help…

Thanks ,

I have exactly the same issue! I have good specs as well and not a single issue on any other daw (tried on latest Studio One and Reaper). I’m using a Scarlett 2i2, and it somewhat happened suddenly - I’ve tried to reinstall Cubase and I’m very reluctant to reinstall my OS, as this should not be a solution to a software problem.