Cubase Pro 9.5 - average load CPU maxed out

Hey hey everyone.

My average load meter is constantly maxed out. Granted I am working on a big project, but do you ever get the feeling that with your computer specs there should be plenty more give?? Or at least, it should not be at maximum capacity…

What are the causes of this?

I can’t say for sure if it’s the 9.5 upgrade, or just Cubase’s inefficiency, or if I genuinely have too many plugins.

I don’t get it!

Any information about the topic would be very helpful, as I’m pulling my hair out…


THANKS

Nope, Mac overall CPU not even close to max. Only within Cubase… Would be good to hear if others are experiencing this?

I am not a Pro at this kind of technical stuff but my guess is that Cubase shows you the realtime cpu load.
With that i mean that, when playing a Project, Cubase has to spit out all audio / midi/ plus FX in realtime, otherwise you would hear audio clicks/dropouts.
This realtime performance Cubase has to do, puts way more strain on your CPU than other CPU tasks that don’t demand realtime throuhput.

The mac CPU metering isn’t showing you (only ?) realtime cpu demands.
Thats why this mac metering is less than cubase cpu metering, cause there is cpu overhead available on your mac for other cpu tasks that don’t have to be realtime.

I am sorry if i am explaining things not very bright for you :wink:

Hmm interesting. That kind of explains the mac CPU headroom, but still it’s an issue for working within the project. It’s unworkable, and I’m not sure if the new Cubase is at fault or Cubase is just inefficient…

With ASIO guard on high, at 512, no tracks record armed, I can touch 100% out of my cores with out an ASIO Spike. Which i thought was impossible until i tried it a few days back. I was testing to see how well the higher ASIO guard setting was performing.

I’m at 2048 sample rate and constantly 100% even when nothing is playing, and huge audio dropouts when I press play. Something is not right, seems very poor performance

Yes, you have have a serious issue with your set up.

zooterman wrote: " I’m at 2048 sample rate and constantly 100% even when nothing is playing, and huge audio dropouts when I press play. Something is not right, seems very poor performance".

I would say the key phrase here is “when nothing is playing”!! Surely this points to your system and not Cubase?

I’m not a computer tech, but that would be my take on it!!!

Good luck solving it though, I’m sure there are a lot of people on here that can help.

Jim B

I had this happen at few times during the fist times I worked in 9.5 - seems to be gone now.

Thanks Lasso, makes me feel better.

For now I am using Direct Offline Processing to very good CPU-saving effect.

yeah well - today working on a song with just medium load recording wouldn’t start on midi tracks because playbackstart created a cpu spike. Setting asio guard to hi / max solved it. Still strange.

Same CPU issues and the solution for me was to change project sample rate to 44100Hz from anything higher you may have.

(Backup your project before downsampling just in case, Cubase will ask you to convert audio). Not a single dropout after. Asio-Guard disabled, buffer at 1024. Load meter dropped about 20-30% and stays there.

I also switched to 32bit Processing precision (Studio > Studio setup > VST Audio system) as not many of my used plugins supported this. To check go to: Studio > VST Plug-in Manager, press downward arrow near the search box, select “Show plug-ins that support 64bit processing”.

Hope that helps.

Hi, someone are use manys Fabfilter L2 with oversample on? that could be the problem, iam working on i7 7700K, 16GB and i have, on a normal project ( 10 midi tracks and 15 audio traks ), low CPU usage.

One thing that can instantly destroy performance of a heavy project is having the midi track of a vsti selected in the project tracklist. When mixing I make sure this isn’t the case. Just select an audio track instead, see if performance improves. If I need to add midi, I temporarily suspend processing with the button at the top left of the project window. That may be the problem if you are overloading when play is stopped.

1 Like

Ive just changed soundcards from a UAD apolllo quad firwire (still for sale btw) to an Audient iD22 and experiencing massive performance issues.

The cpu load spikes in projects that were fine before, with the same settings (512 / 1028 samples, 44.1khz bits).

I thought the UAD would only process the UAD plugins so changing soundcards wouldn’t affect it?

Cheers

Hi,

Sorry for the late reply.
Below is my experience:

My name is Tony El khoury and i’m a film sound designer and I work on nuendo 7.
Our current project is a 7.1-96khz project , with almost 860 sound editing tracks.
The project is running on a cheap M-audio fast track ultra8R discontinued 2.0 USB soundcard and WINDOWS 7…

The fact that your system CPU is not maxing out, that means your problem is within the DAW!
I’ve faced this issue many times and here’s what I learned:

1- The higher the sample rate of your project the heavier the project gets, if you can reduce it, your DAW would thank you for it

2- Whenever you are using USB 2.0 based soundcards, your system has a limited amount of tracks it can process , upgrading to a 3.0/Firewire/Thunderbolt/PCIe system wound greatly improve your track count and real time processing power

3- Average Load spikes is affected by the number of tracks , insert/send effects on tracks and most importantly number of clips in your project. The more you consolidate your tracks the better your performance will become.
A great solution would be to start freezing tracks , and reducing inserts plugins on other tracks (create FX channel tracks and use sends instead) .

4- Low buffer size means high average load, bring your Buffer size to the maximum that your Asio offers you if you are mixing and find a balancing when you are recording (you can also use delay compensation). Also don’t forget to use ASIO guard on HIGH, and boost audio performance.

5- Outdated soundcard drivers could also cause this problem, Try to update to a newer version, and keep in mind compatibility issues , sometimes you need to install an older version of your driver in order for the soundcard to work properly (just like my case, because my soundcard is discontinued)

6- Run a compatibility test to your DAW and Soundcard drivers, sometimes they are not supported by your system if it is too new or too old. (right click on the .exe file , select troubleshoot compatibility)

7- Upgrading your CPU will HIGHLY relieve your Average load and overall System CPU spikes…Research what’s the best compatible CPU that you can get for your motherboard within your budget , and don’t think twice on upgrading (was the greatest decision I’ve ever made and i’m currently running on an i7 5870K CPU @3.3GHZ)

Also sometimes all your problems could be because of ONE plugin, and believe me it happens !!
I was using a 32bit plugin extensively and when I removed it from my inserts, it drastically reduced my average load. What I recommend is that you create a new save file and start removing each plugin at a time and checking which one is loading your DAW. When you find it, either use a lighter plugin or freeze your tracks.

Don’t forget to optimize your SYSTEM (remove c-states, hyper-threading, over-clocking) and changing your power plan to HIGH PERFORMANCE. As well as disabling running background apps that you don’t need. Remove visual effects in “Performance options” in your windows and in the advanced tab adjust for the best performance of “Programs” instead of background services.
Also load your project on a De-fragmented hard drive or even better on an SSD.

That should be it!
Apologies for maybe giving solutions more than you actually need, but all of these will greatly improve your work-flow…
Working with cheap equipment requires you to find solutions .
And if you feel like you have a bug in your system, think like a bug :slight_smile: Your solution could be the weirdest solution
and don’t be afraid to experiment.

On a side-note , if you are using WINDOWS 10 , I would highly recommend that you downgrade to WINDOWS 7.
Windows 10 is very buggy and is not the best platform for Music and Sound production.
Windows 7 allows you to better control your features, has less useless background running apps and allows to stop
windows updates with a click of a button.
Also, piece of advice, don’t use Internet on your Music and Sound production operating system…


Cheers,
T.K

1 Like

i never had problems.

but within the last few weeks the situation creeps in that after few minuteof the cpu meter at around 40 it jumps to max and no audio is possible.

after some minutes of me waiting it willgo back to around 40 percent.

after some minutes of work it comes again.

can i change a project to 44.1 after i have already recorded most stuff at 48?

will go to 44.1 on future projects.

sample rate is at 512

asio gard on highest priority is better for cpu? will try

You were going really well there, with lots of really good advice, and then you went and said this. :wink:

In my experience, Win10 has been really good for music production with CB9.5.x. No problems attributable to WIn10, and rock solid CB performance over 18 months. Win10 also has fundamental improvements over win7 when it comes to audio. I like Win7 too, but there is nothing wrong with Win10, and I would be very surprised if that is the OP’s problem.

I agree about the win10 updates - I don’t like having updates forced on me, but at the same time, these updates can be important for security, and if you really don’t want them, you can at the click of a button delay them for up to a year. I have yet to have a single CB problem caused by win updates or by my CB machine being online. In fact, just the opposite - it makes it easy to do updates. I allow win10 to do all critical updates ASAP to maintain security, but I delay the big updates - new win10 build releases - for up to a year.

But yeah, all your other advice was very good.

I’ve had this problem before, I would usually augment the sample size to 1024 minimum , and in device setup/VST connections use ASIO guard, and multitasking + Boost audio priority - Un-tick Steinberg Audio Power Scheme… How is the load on your projects? Do you have too many plugins? or vst instruments? Also consider updating your sound interface sometimes it could be the cause of your problems…
The higher the sample rate of your project, the more processing power your project would need most probably so I would suggest trying to convert your project to 44.1 and see if the problem persists too…And don’t worry it’s easily doable, just change the project sample rate and the cubase/nuendo would automatically convert your tracks

Well i’m currently using nuendo 7 , not sure how new versions would interact with win 10…Nonetheless you might be right, but it also depends on a lot of factors, I think each case should be taken individually…I’m working on a huge project with approximately 900 tracks including VST instruments, plugins (both inserts and sends) all on a very crappy USB2.0 soundcard…In that case I would stick to what is mostly compatible with low budget equipment :smiley:
Plus, win 7 has a lot less background processes and running apps that you can actually deactivate, unlike win10, in my case i’ve saved lots of CPU and memory just by downgrading and optimizing win 7…Had lots of bugs with win10, not sure why.

Anw cheers! Hope you found my advice of good use :ugeek: