Cubase Pro 9 Latency issues

I recently changed from Nuendo 3 to Cubase 9 as upgrading from Nuendo 3 was not allowed and purchasing Nuendo from scratch was out of my budget. While recording audio on Nuendo, I sometimes didn’t use “direct monitoring” on the Hammerfall sound card when I wanted to add processing to the audio being recorded during the recording. I cuuld always adjust the latency on Hammerfall so that the performer could still play or sing without having a perceivable delay in their headphones.

In Cubase 9 64 bit, I can run Hammerfall at the lowest latency and get away with it without clicks etc. which was impossible on Nuendo 3, 32 bit. But the latency from Cubase stays extreamely high at all times so recording a singer / guitarist is impossible. I have to do all audio recording now with “direct monitoring”. Is there some other setting I am missing?