cubase slows down after lots of edits and cuts. Are there solutions other than bounching??

I am slip editing multple tracked drums and I use group edit function.

When I use the cut tool, it takes over a second before cubase has processed the cut. In other words, after I have clicked with the mouse, nothing happens for over a second.
yes, I understand that if I had a faster computer this would go faster, but is there another way to optimize things
so that cubase would be able to do this faster. Is there something inside cubase I can turn off during this moment of editing for example?
I have already optimized my computer for music production

thanks!

also

I realize that things started to get slower and slower the further I got in the song ( it is a long song)
so apprently when there is a lot of cuts this causes Cubase to slow down. This means that
I can bounce down the edited parts and this will make cubase work faster again.
but are there other ways?

I would just suffer thru it, but then bounce/consolidate to a new track version when I’m done the edits.

I’ve experienced the same thing with a large number of edits. I used a workaround similar to your second post with doing a chunk of edits, then creating a new track version and bouncing those edits. Then do the next chunk of edits, create a new track version and bounce those edits. Repeat until you get all the edits done. I tried pulling up the project to take a screen shot, but can’t find it at the moment. The track version list would look something like:

Edits mm1-25
Edits mm26-50
Edits mm51-75
Edits mm76-100
Etc.

This way you still have the edits available if you need to go back to tweak something and each successive version contains all the bounced edits of the versions prior. For instance:

Edits mm1-25
Edits mm26-50 (contains bounce of measures 1-25)
Edits mm51-75 (contains bounce of measures 1-50)
Edits mm76-100 (contains bounce of measures 1-75)

Hope that makes sense. Additionally, here are some things I found to help out a bit that I’ve posted elsewhere:

Hitpoints: Select all audio events then go to Audio -> Hitpoints -> Remove Hitpoints. I noticed using the “Create Events from Hitpoints” made the GUI lag like crazy so this helped a bit.

Also worth a shot to turn off “Enable Automatic * Hitpoint Detection” from Preferences -> Editing -> Audio (it’s the last checkbox listed in that menu).

Using slip editing for edits seemed to get around the lag from hitpoints (which you’re already doing)

Turn off “Background Color Modulation” from Preferences -> Event Display -> Audio (last checkbox listed)

Limit the number of tracks visible on your screen. Use folders and hide any tracks you aren’t currently editing. The less tracks on your screen means Cubase doesn’t have to work as hard graphically to display waveforms and whatnot

Increase buffer size

Maybe try changing the ruler display if it’s currently set to “Bars and Beats.” I noticed a significant improvement if I changed my ruler to “Timecode” or “Seconds”

Here are a few other posts I found that may also be helpful to you:
https://www.steinberg.net/forums/viewtopic.php?f=226&t=92642&start=25
https://www.steinberg.net/forums/viewtopic.php?f=286&t=173290 (third post has about five links to other posts dealing with the sluggish GUI issue)

wow, thanks, that was great advice, just when I needed it, thanks!

No problem! Hope those help!

Thanks for the tips

Hey - Thought you might like this tip.

After weeks of sample editing I have thousands of cuts and the response is very slow.

Try ‘quick zoom’ in Edit > Preferences > Editors > Quick Zoom

Really worked. It doesn’t force you to wait while it redraws the graphics.

Freezing tracks should help as well with edits related slow downs, this way you don’t have to bounce if you think you want to make changes.

Could utilize track versions for this as well, ie, duplicate track version → bounce