Cubase sometimes doesn't detect remote midi device

I’m having a very strange problem, please tell me what to do.


  • Cubase may not be able to detect signals from remote MIDI devices (There are no any signals bottom right of the screen on Cubase)
  • I could have connected and used MIDI devices under the same conditions in the past, but once the connection is disconnected, the signal cannot be detected.


  • PC

    • OS: Windows10
    • Software: Cubase 11 pro
    • MIDI App:Protkol
  • iPad

    • OS:iOS14.6
    • MIDI App: Touch OSC
  • Protokol/Touch OSC

    • I made the settings according to the following procedure and confirmed that communication was possible without problems. Introduction · TouchOSC |
    • It looks like correctly receving the operation of the iPad, so there is no problem with the connection between the PC and the iPad.
  • Cubase


  • I tried connecting MIDI devices before / after starting Cubase, but it doesn’t change.

Hi and welcome to the forum,

I don’t know, if this is the case, but there is known issue (at least on Mac), several virtual MIDI Ports (including TouchOSC) act as a new MIDI Device (for all Remote Devices) after quitting and restarting Cubase.

So if you prepare any Generic Remote Device, quit Cubase and restart it, you need to remap the MIDI Input and Output of the Generic Remote Device (when using TouchOSC).

Could you try this, please?

1 Like

Hi Martin! Thank you for your support!! but it doesn’t work.

I guess that the signal will be displayed even if the mapping is incorrect.
So I doubt the connection between Remote Device and Cubase.
However, I am in trouble because there is nothing that can be changed other than MIDI mapping and MIDI port settings.

What I did

  • Remove Old Device
    • “remove selected device”(Generic Remote = Touch OSC) on Studio Setup.
  • Add New Device
    • “Add Device” (Generic Remote) on Studio Setup
    • “Import” (test.xml) and apply
    • quit Cubase and restart Windows
  • Test New Device
    • launch Cubase after connected MIDI device


What is your expected result with this settings?

As you set it up as Generic Remote, you cannot record these MIDI data to the track from this device. These specific MIDI data are blocked (to the track) by the Generic Remote.

If you want to control the parameter (Volume of track 14 on this case), enable Automation Write, please and then write the fader movement.