Cubase Studio 5..5.3 update won't install


I have Cubase Studio 5.5.2 installed in 64bit and I just tried to install the 5.5.3 update, but nothing happens, I tried several times, even downloaded it again, but same thing. It just won’t install, I just get a very short little progress bar on the screen, but it’s only on there for a split second and then no matter how long I wait, nothing happens.

I hope someone can help me!


PS I know it says Cubase 6 in my sig, and I have that as well, but I also still have Cubase Studio 5 installed :slight_smile:

I had the same problem and then found out how to fix it. You must make sure you download the correct update. There are two versions. One is for CUBASE STUDIO, and the other for CUBASE.

I had studio and was trying to update it with the NON studio update… that was the whole problem!


but I did download the correct update, I did check on that twice. :slight_smile:

Very strange: I just tried to run the installer again, and this tie it worked…

I don’t understand, since I tried ti yesterday several times (at least 5 times and I also rebooted in between), and now I try again, and voila, it worked.


Hi. I also have problems installing 5.5.3 update. I have Cubase 5.5.2 on a 32 bit PC (Intel Core 2 4300 1,8 GHz).
When I try to update to 5.5.3, after a while it says “Installer application stoppet working” and all I can do is to stop the installation (close program).