Cubase Studio update failed


I just tried to install the latest Cubase Studio Update (5.5.2), but it got stuck, and I waited a fe minutes but nothing happened. Then when I hit cancel, it got stuck again. The installer did not react. Not even going to the task manager and canceling the process there helped any.
What is happening here?
Am I doing something wrong?
My current version is Cubase Studio 5.0.1.
Do I first have to run every previous update form 5.0.1 onward before I can install the latest update?

I hope someone can help me.


5.5.2 should go straight onto any version of C5

Thanks !

Now I rebooted my PC, well actually hit the ‘reset’ button on my PC (which caused Windows to do a CHDSK : C)
And then I installed the update again, and this time it worked, but:
Now my Cubase desktop icon had this little ‘administrator’ shield symbol ?! What is that supposed to mean???

Also I got a message saying the e-lincenser had a problem and was de-activated???
Weird thing is : I only used a USB licenser so far, why do I get a message about a soft-e-licenser at all?

I’m getting tired of all this…so confusing.
All of the 64 bit upgrade was supposed to make my work on the PC easier but until now it’s been the opposite…