Cubase to ignore specific Midi messages?

Can anyone cleverer than me tell me how I can filter/exclude a specific midi message from a specific local midi device? I have a Midifighter Twister connected to my Cubase 13 Mac by USB. I want Cubase to ignore the note on and off midi messages CC0, CC1 , CC2 & CC4 (on Channnel 4) from the Twister - any idea how I can do it?! Midi filter in Preferences looked like the solution but I don’t think it can do it…
The problem is that the Twister is sending those messages when I change its bank/page and it’s messing with whatever is on the active Cubase track (Kontakt/Zebra2) etc

Many thanks

In which way are you using the twister? If it’s for DAW controlling, you can exclude it from the “in ALL midi inputs” thus it will not interfere with your plugins.


This one would filter the whole device (MIDI Input Port). My undersigned is, he wants to filter just some dedicated MIDI Messages.

Therefore I would use the Global Input Transformer.

1 Like

Sure. The thing is that many times, it’s clearer when it’s possible, to have dedicated ports for DAW and plugins handling, this is why I presumed that to be a port for DAW handling :slight_smile:

1 Like


Then the question is, how exactly is it integrated to Cubase. For example Quick Control, MIDI Remote, or Generic Remote messages are filtered automatically and they don’t pass into the track, even if you use the given MIDI Port.

At the other hand, for example Mackie Control pass the data thru to the tracks.

1 Like

Exactly. Internally Cubase consumes messages properly, and yes, I don’t quite get why this is not the case with Mackie. I have to guess that messages in the past were coming in the same port, for stuff like pads etc. I remember when I first bought a Mackie compatible device, began recording, and upon automating, I started hearing the faders pitchbending my selected track! It was such a surprise and I was too perplexed. Since that day, I always get to know first what ports are doing what to avoid this traumatic experience :joy:

Thanks both - disabling the Twister from ‘All Midi Inputs’ seems to have worked perfectly… I just don’t understand why all the other commands that I have set up still do work?
I’ve mapped the Twister to do lots of jobs in the Midi Remote Mapping Assistant that are for the ‘Selected Track’ i.e. Volume (of Selected), Pan, etc… and also the QC’s for all 8. Also the Metronome Loveland Automation toggle… all still working.
Just so I understand - is this because these commands are kind of ‘software’ based midi commands that go on under the hood? And that the 'All Midi Inputs is more like a physical and more direct type of midi straight to the track?

Sorry, I’m not being very clear, but I think you’ll know what I mean. I always find it more beneficial when I know exactly why something is fixed!

Either way - thank you both so much as it seems to be doing exactly what I need!

Yes, the All MIDI Inputs option has to do with tracks. They are the MIDI ports that the tracks may listen to, if of course you don’t set a specific port to listen to.
Using the Midi remote, you’re actually again telling Cubase to listen to the ports you define, specifically for DAW handling, if you uncheck them from the All. You can still let these ports to your all MIDI inputs, however, it can lead to conflicts, and I personally prefer to distinguish ports for each case.

1 Like

Wow that is really good to know. I always thought that All Midi Inputs was listening to everything in every destination - good to know it’s just the tracks. I might disable a few others just to keep things simple.

Many thanks for clearing that up!