Cubase und Guitar Rig: Controller reagieren nicht auf Midi

Hallo zusammen!

Ich bin als Umsteiger von einer anderen DAW absoluter Neuling bei Cubase.
In Cubase 7 Elements habe ich als Plugin in einem Softsynth Guitar Rig 5 integriert.
Ich möchte in Guitar Rig den Controllern nun verschiedene Midi-Steuerbefehle zuweisen.
Das ist leider nicht möglich; auf Midi-Learn erfolgt keine Reaktion.

An anderer Stelle von Cubase (Steuerfeld rechts oben) erscheinen die Midi-Impulse als Ausschläge. Der Midi-Input scheint also registriert zu werden.
Er kommt leider nur nicht bei Guitar Rig an…

Hat jemand eine Idee?

Danke!

  1. Der Midi-Eingang von Guitar-Rig muss auf den richtigen Midi-Port eingestellt sein (auf dem die Controller-Daten ankommen), im Zweifelsfall mal auf “Alle” stellen.

  2. Die Guitar-Rig-Spur muss zum Empfang entweder ausgewählt sein, oder der Monitor-Button aktiviert sein.

Und wenn’s dann immer noch nicht klappt, ist vielleicht ein Midi-Filter in den Programmeinstellungen aktiviert, der die Controller-Daten abfängt (keine Ahnung, ob’s die Funktion bei C. Elements überhaupt gibt).

Viel Glück!

1. Der Midi-Eingang von Guitar-Rig muss auf den richtigen Midi-Port eingestellt sein (auf dem die Controller-Daten ankommen), im Zweifelsfall mal auf “Alle” stellen.

Das habe ich gemacht.

2. Die Guitar-Rig-Spur muss zum Empfang entweder ausgewählt sein, oder der Monitor-Button aktiviert sein.

Monitor-Button ist aktiviert. Was heißt Guitar-Rig-Spur? Das Plugin ist doch in der Softsynth-Spur integriert (Insert). Muss ich da noch etwas anwählen?

Und wenn’s dann immer noch nicht klappt, ist vielleicht ein Midi-Filter in den Programmeinstellungen aktiviert, der die Controller-Daten abfängt (keine Ahnung, ob’s die Funktion bei C. Elements überhaupt gibt).
Vielleicht kannst du mir einen Tipp geben, wo ich die Programmeinstellungen mit dem Midi-Filter finde. Das könnte eventuell eine Möglichkeit sein.

Vergiss das mit dem Filter, das war’s sicher nicht. Probier mal Folgendes (Beispiel Wah-Pedal mit externem Midi-Pedalboard steuern):

  1. Inserte innerhalb Guitar Rig den gewünschten Effekt, in diesem Beispiel das “Real Wah”.

  2. Öffne Menü “Geräte -> Geräte konfigurieren” und gehe dort in den 1. Ordner “Fernbedienungsgeräte” auf “Spur-Quick-Controls”. Unter “Midi-Eingang” steht “All Midi Inputs” und unter “-Ausgang” “Nicht verbunden”. Das kannst Du so lassen.

  3. Dann wähle das QuickControl1 aus, mache in “Lernen” einen Haken und betätige Dein Fuß-Pedal.

  4. Klappe in Deiner Audio-Spur mit Guitar Rig als Insert die Quick Controls auf, schalte sie an (blauer, erster Knopf) und klicke in den ersten Slot darunter. In der Liste musst Du jetzt den zu steuernden Parameter finden (in Suchfeld “Wah” eingeben, oder “Guitar Rig”, und dann dort unter dem gefundenen Eintrag den Parameter “Real Wah Pedal” auswählen. Mit anderen zu steuernden Dingen müsste es in gleicher Weise funktionieren.

Jetzt sollte beim Betätigen des Pedals das Wah angesteuert werden. Ich hatte das Alles etwas anders in Erinnerung, z. B. dass ich innerhalb von “Guitar Rig” das “Learn” machen musste, aber das war wohl im Stand-Alone-Modus.

Ich hoffe, jetzt klappt’s. Viel Glück.

“2. Öffne Menü “Geräte -> Geräte konfigurieren” und gehe dort in den 1. Ordner “Fernbedienungsgeräte” auf “Spur-Quick-Controls”.”

Leider scheitert es schon an diesem Punkt. Den Menü-Punkt Fernbedienungsgeräte und Quick Controls gibt es nicht. Die Bezeichnung Quick Controls habe ich auch nicht in der Anleitung von Cubase Elements 7 gefunden.

“Ich hatte das Alles etwas anders in Erinnerung, z. B. dass ich innerhalb von “Guitar Rig” das “Learn” machen musste, aber das war wohl im Stand-Alone-Modus.”

Das finde ich ja schon mal schade, dass man die Controller-Funktion innerhalb des Guitar-Rig-Plugins nicht nutzen kann…

Ok, die Einschränkungen von C. Elements kannte ich nicht. In diesem Fall musst Du anders vorgehen:

  1. Lege eine neue Midi-Spur an.
  2. In dieser muss der Midi-Ausgang auf die Guitar-Rig-Instanz zeigen, die in der Audio-Spur geinserted ist. Evtl. gibt’s bei Dir nur eine einzige Instanz, je nachdem, ob Du mehrere Guitar Rigs in Spuren geinserted hast.
  3. Der Midi-Eingang muss auf Deinen Midi-Port eingestellt sein, wo der externe Controller dran hängt. (Achtung: “All Midi Inputs” funktioniert bei mir in diesem Fall nicht!)
  4. Bei der Midi-Spur den Monitor-Button betätigen, oder sie auswählen. Jetzt Midi-Learn im Rig für den gewünschten Parameter aktivieren und externen Controller betätigen. Nun sollte das Ganze funktionieren.

Hey, the.slider, danke. Das funktioniert schon einmal. Schön (wenn auch nicht ganz unkompliziert). Vermutlich muss ich dann für jeden Softsynth, der eine eigene Guitar-Rig-Zusammenstellung benötigt, auch eine eigene Midi-Spur anlegen, oder?

Noch eine kurze Frage:
In meiner alten DAW hatte ich für die Midi-Controller von Guitar-Rig schöne Voreinstellungen angelegt. Leider sind nur die Racks gespeichert, aber nicht die Einstellungen der Midi-Controller. Es wäre super, wenn ich die Controller-Einstellungen einfach übernehmen könnte. Weißt du, ob das irgendwie geht?

Ja, genau.

Dazu kann ich Dir leider nichts sagen, habe ich nie gemacht.