cubase upgrade

My cubase shows me that there is a new upgrade fixing bugs and other stuff and it shows me the 8.0.20, but then when I go to the website to download it , it ask me for MAC O.S. 10.9 AND I am running the 10.8.5 .
Should I let it as it is? or can i download it and install it?…

help…!!