Cubase will not recognise audio drivers

I am using Cubase SX 3 on Win 7 x64. It was working perfectly, so this is not a situation where the drivers/version are incompatible, etc. In fact, I have a slew of ASIO/audio drivers; one for Presonus audio box; another for a USB keyboard; and some others. These all used to show up in the Device manager; I could choose which one I wanted to use. As a Presonus Audiobox user, I would naturally select that ASIO driver. Everything had worked fine.

The PROBLEM: Cubase SX3 now shows only 2 Master ASIO Driver selections: 1) ASIO Multimedia Driver; 2) ASIO DirectX Full-duplex driver.

Fruity loops works fine; sees my audio drivers; allows me to select one. A few other products also see them; allow me to select. So, it does not appear that it is a problem with several other ASIO drivers.

What I have tried, thus far: uninstall Cubase SX3 and reinstall; uninstall Audiobox driver and reinstall. In my opinion, the Audiobox driver install/re-installation was unnecessary, as Cubase is not displaying any of the other ASIO/audio drivers either.

The DETAILS; what I’m seeing:

  1. Cubase comes up and the ASIO Multimedia test wants to run; runs and displays the Realtek Digital Audio driver that is native to my motherboard/machine. It’s successful. However, this is not the right driver to use…need to select my AudioBox ASIO driver.

  2. The Device Setup; VST Audiobay; Master ASIO Driver selections show: ASIO Multimedia Driver; ASIO DirectX Full-duplex driver. And herein lies the problem…the rest do not display. Typically, one could just go in here and select the right one, but they do not exist! I cannot make the right selection if it does not exists. The only consistency here is that all of the others- apart from the 2 I listed -do not display.

  3. If I go into ASIO Multimedia Setup my Audiobox 22VSL driver and my PhotonX25 divers show up under “Output Ports” and “Input Ports”! And, they are active. I can click “advanced” and see them, again; with the “X” checked off to indicate they can be used.

  4. When I bring up Cubase, they are missing from the Master ASIO Driver selection list.

In Summary:

I’ve wasted a day, so far; cannot get this one. Usually a re-installation takes care of things. If anyone can point me in the right direction, I’d be very grateful. Right now, I have several unfinished projects that I cannot access.