Cubase Won't Close After You Exit The Project

I also know this problem. And many others do so. Here is an older thread about this topic:

I have a kinda workaround solution :smiley: I already posted it in the other thread but i repost it here:

I wrote a little programm to kill cubase everytime this happens.

Open Notepad and write:

taskkill /F /IM Cubase9.5.exe /T
taskkill /F /IM Cubase9.exe /T
taskkill /F /IM Cubase8.5.exe /T

Cubase 9 and 8.5 are optional. Just wanted to show you how it works with more than one cubase versiosn. You can kill every .exe program you like.

Now save the file with the ending > .bat > something like "Kill Cubase> .bat> " Now you can create a shortcut to the desktop if you like. If you want to put the shortcut on the windows taskbar you have to change one little thing. Open the settings for the shortcut and write in the > Target: > tab > %windir%\explorer.exe[SPACE] > before your initial target. Also delet the > " > before and at the end of your initial target. so it looks like:
Target: > %windir%\explorer.exe D:.…\Kill Cubase.cmd
After that you are able to put the shortcut on your taskbar. You can also change the symbol if you like.

I know this isn’t the best solution but Cubase gets stuck almost everytime I close it. With this solution I don’t have to open the taskmanager everytime. I just click one Icon > :slight_smile:

1 Like

I use VSL with Cubase a lot. I didn’t have a problem with this issue until I upgraded my Vienna Instruments Player to a new version. Now most of the time, I get errors or it hangs when I try to close Cubase.

Mine hangs for roughly 10 seconds then i can close.

Yes, there does seem to be some correlation with Windows updates. I’ll go months with no problem, then I get a Windows update of some kind (I think the most recent one was the big one in April?) and then it starts happening again. Every frickin’ time I have to kill the process.

AND I WOULDN’T BE UPSET IF IT WEREN’T FOR THE FACT THAT CUBASE DOESN’T SAVE ITS SETTINGS UNTIL IT EXITS. WHICH IS INSANE. IF IT WOULD SIMPLY WRITE SETTINGS AS IT WENT ALONG, IT WOULD BE A NON-ISSUE.

[/quote]
AND I WOULDN’T BE UPSET IF IT WEREN’T FOR THE FACT THAT CUBASE DOESN’T SAVE ITS SETTINGS UNTIL IT EXITS. WHICH IS INSANE. IF IT WOULD SIMPLY WRITE SETTINGS AS IT WENT ALONG, IT WOULD BE A NON-ISSUE.
[/quote]

and still… still… no changes… still the same thing…

1 Like

I just solved topic problem. Yep.
In my case turn off ‘use hub’ in preferences do the job. Version 10.5.

Some connection issues on quit probably a reason.
Is it helps?

3 Likes

Thank you, my man. It really WORKED.
Tick off the Hub thing on preferences and Cubase will close as it should.
Great stuff!

This worked for me too on 10.5 :sunglasses:
THANK YOU

Oh dear after suffering from this shutdown problem for a few years now I just tried turning the HUB off in preferences as suggested…IT WORKS
The amount of times I’ve had to redo prerefences. Thanks Guys
Cubase 10.5

Yes… Really strange thing…
this helps a lot.
thanks.
worked for me too.
with cubase 10 and 10.5 both had this issue. (may be after updating to 10.5, not sure.)
but this trick worked for me., thanks.

Still having this issue after 10.0.60 update.

Incredible.

Are you a wizard?
Finally, I’ve been struggling with this for sooooo long.
Cubase Pro 10.0.60 - solved.

Perfect - this solution (turn off “Use Hub” in Edit>Preferences>General) works well for me too.

Configuration summary: Cubase 11 Pro, Native Instruments Komplete Audio 2

2 Likes

I have Pro 11 and you’ve just made my day! Thanx a billion

I Have found that if i go to file “CLOSE”" then “QUIT” that does the trick for me.

Hi there, I’ve been having this problem quite frequently since 10.5 (then on 11) on my Win 10 DAW. It even got to a point where I had tried pretty much ALL the tricks listed in this thread… turn off the hub, etc. The taskkill commands weren’t doing anything for me and the cubase.exe would even prevent my computer from shutting down properly (I had to force it to shut down). About two weeks ago I did a delete/refresh of the user preferences, which seemed to help for a little while but then the bug started happening again…

Then, while Cubase was (once again) refusing to quit, I tried disconnecting/reconnecting my MOTU Micro Lite MIDI interface and poof : Cubase instantly quit. Since then, every time cubase.exe refused to quit, disconnecting the Micro Lite solved the problem right away.

So I guess in my case the problem is mostly related to the MOTU drivers. I wanted to share this here in case other users on the forum have MOTU hardware. I had noticed on quite a few occasions that the Micro Lite would sometimes become “invisible” to Cubase, even though it was connected and powered on… I would often have to reconnect it and restart Cubase. I also had a MOTU audio interface which had similar problems. I made sure in my Windows preferences that USB selective suspend was off, etc but it never made any difference. Upgrading drivers/firmware is not an option either because MOTU haven’t updated their MIDI drivers since 2013 (hello ???).

I am glad I finally upgraded to RME. The audio and MIDI drivers are rock solid so far. Unfortunately, my hardware synth setup is a bit complex and I still need to use some of the ports on the Micro Lite…

Thanks a lot! This helped!

Same for me in Windows 10. Thanks for the tip. i won’t fall crazy :slight_smile:

Turning of the hub in Cubase 12 still required.

This fixed my issue as well in Cubase Elements 12, Also Cubase opens faster as well.
Thank you.

I have been battling this for years, and decided today I was going to discontinue using Cubase and start using Reaper full time, but found this solution.