Cubase won't recognise USB mic as input on new laptop, even with Asio4All


I use a USB mic to record into Cubase and until now have successfully managed to do so using Asio4All driver.

However I’ve just transferred Cubase to a new computer and now Asio4All doesn’t seem to recognise my mic.

The generic ASIO does now recognise my mic (it didn’t on my old laptop) but I get distorted/clicking audio on it, even if I convert the the project to 48khz. It also only recognises left/mono audio input whereas it should be able to do stereo

Does anyone have any suggestions? I’ve already tried quite a few things based on answers to other questions so I don’t know if anyone would be up for doing a screen share call with me?

Thanks in advance!

Hi and welcome to the forum,

Try to increase the Buffer Size, please.

If I increase the buffer size, the audio is less distorted but it stops and starts really badly every half second so it sounds very jerky. If the buffer size is too low, it sounds very flicky, like helicopter propellers. 68ms seems to be the best buffer size but even that sounds bad.


68ms is definitely far from the real time…

I would go for the ASIO4ALL. You said it doesn’t see your Microphone. Do you mean it’s not in the list at all? Do you have the latest Microphone driver installed, please?

It’s not in the list for input. The only names of mics that appear in the input list are these:

In the output list it does recognise my mic (my mic has a headphone port):

I have the latest Asio4All installed as well as the latest windows mic driver installed.

It occurred to me that intcdmicwave could be another name for my mic but it doesn’t pick up any signal when I try and record.


Could you please attach a screenshot of the ASIO4ALL Control Panel, please?


On my previous computer the name of my mic ‘RODE NT-USB Mini’ was listed in the WDM Device List

Okay I have now got good output by ticking ‘Always Resample 44.1kHz <> 48kHz’ and converting the project to 48kHz, but still no input

Okay I’ve solved the problem by downloading and using FlexAsio and it all works great!
Thanks so much for your help anyway!

1 Like