Cubase9.5 - User custom UI color settings does not be applied

When customize color setting in preference and re-launch C9.5, customized color is backed to default color value.

I did fixes temporarily by the following procedure.

  1. Open Preference
  2. Customized color settings
  3. Store preference preset only section of “User Interface”
  4. Open stored xml file and “UserPreferences.xml” by text editor
  5. Overwrite / Marge xml tag manually
  • SurfaceSchemeColorSetPreferences9


  • TrackDefaultColorPreferences


  • FaderColorPreferences


  • RackColorPreferences


  • StripColorPreferences
  1. Re-launch C9.5. Color settings applied.

Hi,

Make sure Cubase doesn’t crash while quit, please. If Cubase crashes, the change is not written to the preferences.

Cubase does not crash while quitting (*1). UI color settings does not be applied. However any other settings has been applied.

*1 At least, application crash dialog has not shown from OS.

OK, if other settings is applied, then Cubase doesn’t crash and the storing mechanism works (in general).

I will try to reproduce it from your step-by-step description tomorrow.

I uploaded video to Youtube for reproduce it.
https://www.youtube.com/watch?v=ZPL6AATEhRU

*** Please enable “closed captions function” in Youtube player for see detailed descriptions.**

Hi,

Thank you for the video. I can reproduce it, now. The trick is, you have to call it from the preset. If you set it via mouse, then it works.

I will report it as a bug.

EDIT - This method works. I must have had Cubase open when I did this. I have just repeated the copying/merging with Cubase closed - and I have my colours on startup of a new project.

Unfortunately Cubase 9.5 Appears to overwrite any of the changes - taking it back to default (user colours at least).
Making the file “read only” would not be a good solution.
It’s a shame that such simple things are overlooked. Is there an “on startup” macro that can be made, that loads in the user presets?

Thanks.
T

Hi,

Could you be more specific, please?

From my observation Cubase stores the settings while you are making it (actually when you quit Cubase after). But it doesn’t store it to the preset. So you cannot call it from the preset later.

Do you have other result?

sorry - No I have exactly SAME result as the youtube video. my preferences HAVE to be applied via Cubase Preferences> Preference Presets>“my saved preference” . They are not Automatically applied to a New Project.
I have no problem making new presets with different names and recalling them from the Cubase Preferences> Preference Presets" dialog.

EDIT - Razuu’s workaround (Copying the values from personal file to userPref’s.xml) DOES work. 1st attempt: must have had Cubase open when I did it. I have just repeated the copying/merging with Cubase closed - and I have my colours on startup of a new project.

Some notes:
Cubase’s “User Interface -Color Scheme” IS applied on a new project. So that preference definitely saved.
Using “Store Marked Preferences only” makes no difference.
Razuu is on Windows OS - I am on Mac OS Sierra 10.12.6.

Thanks
T

same in Cubase 10.0.2,

Hi,

Once you change the preferences, you must not save it as a preset. If you do it, the settings is lost. It’s a current bug.

What settings exactly doesn’t work on your side?