Cubasis 2.8.3 - Unregistered and unable to download RoomWorks SE

Last night I purchased Cubasis 2.8.3 and so far it works fine and starting to find my way around it. However I’ve not been able download the free Cubasis RoomWorks SE. Within the RoomWorks SE window it currently says that I am unregistered. Straight forward I thought. However, when I click on the Free button I get a blank page, nothing else it just sits there (it goes past the message to say click here if I do not get redirected).

I’ve copied the link and tried both Chrome or Safari on the iPad but when I paste the link I get a blank page again again.

In the end I sent a copy of the link to my desktop and the link works and I have managed to register Cubasis in mySteinberg my products page.

Despite mySteinberg saying Cubasis2 is now registered the app doesn’t think its registered nor can I download the RoomWorks SE plug-in

Also tried to reinstall but still the same.

Any help would be appreciated.

Cubasis 2.8.3
IOS 9.3.5 (Latest version available on my iPad)
Ipad 2

Same specs and same problem here…

Has anyone figured out how to register Roomworks SE?