Cubasis 3.4.1 issue (crashes when erasing an audio clip)

Hello :slight_smile:

I work on iPhone 11 Pro (iOS and Cubasis 3 up to date), and after spending some time on any project the app finally freezes and crashes when trying to erase an audio clip.

It’s hard to capture this on video because this takes some time to happen, i didn’t find a specific action that causes it, but it happens everytime… i guess there could be an issue with the Autosave or the Undo history because, when relaunching Cubasis after that, the last operations are missing (sometimes the audio clip is deleted as expected, but most of the time the last 2-5 operations have not been autosaved).

I hope this can be fixed easily. :v:

1 Like

Hi Electrafa,

Working with an IPad Pro 12.9, 5th. Gen, and up to date IOS and Cubasis, I encountered the same issue. Trying to erase a single audio event from a longer drum loop caused the program to freeze every time. I was able to copy and paste the event into a new section, and then erase that one. But every time I tried it on an event I have placed before, it freezes. One bypass I found was using the select option, highlighting a few events at once, then erasing them. And it worked that way. But in any case, I am seconding your call here for this to be fixed in a future update. Thanks all, and happy Music making!

1 Like

Same problem in my android device. Crash and bloq when i erase a audo clip or similar. Any solution? thanks

pd: mi device is samsung galaxy tab s4 android 10

Hi all,

Thanks for your bug reports which has been shared with the team.

Best wishes,


Hi @electrafa, Hi @RichardWormstall1,

Unfortunately we are unable to reproduce the crash problem ourselves.

Firstly, please provide us with the crash reports to allow the team further evaluate the problem. Please upload the crash reports via Dropbox or similar and let me have the download link via private message.

In addition, if you have projects where the issue can be easily reproduced, please share them as well (see above).

Thanks in advance
& stay well,

Hi how i can send my Crash report?

I record a video with the problem
(Delete the first X on the link )

I try this And persist the bug:

-Use the app with Samsung dex Mode And without dex mod
-reinstall the app
-delete Cache app
-use with And without USB interface And with 2 USB interface diferente And persist

1 Like

Hi @isurmx, Hi all,

Unfortunately we are unable to reproduce the crashing issue.

If possible please share a project with us, which shows the problem and allows us to reproduce the issue.

Please upload the project via Dropbox or similar and let me have the download link via private message (please make sure to include the full correspondence).


I have been experiencing the same issue. I’ll be mid flow in a recording session and then out of the blue, when deleting a bad take, the app locks and I have to force it closed and relaunch. I am using Cubasis 3.4.3 on an iPad 6 generation iOS 15.5 128Gb. Using the UR22 MkII

Hi @Colin_Zammit,

Thanks for your message.

Are you able to share a clip with us which shows the steps to reproduce the problem?


I have the same issue ( version 3.4.3 ), and it is very frequent. The UI freezing does happen not only with the Delete button, but with other UI button too ( e.g. had it at least with play or paste i think ). Delete seems to be the most frequent one.
Yes it is sporadic, but i got it several times during 10-20 minutes arrager edit operations.
Repro should be possible by:

  • import 10 audio loops or stems, more and longer makes it more frequent i think
  • cut loops/stems.
  • make several copy&paste operations ( e.g. paste a 2 bar loop to fill a 2 minute track or so )
  • (unclear if more severe) time-stretch some of the loops
  • during this operations, delete some of the audio clips ( can be midi clips also ).
  • it does not depend on specific loops or audio clip. It will not happen again directly after a re-start. There seems to be a UI deadlock issue somewhere. Nothing more nothing less.
  • or in short make e.g. a remix or such with Cubasis. Likeliness to observe it is greater than 50% in 1 hour. Cubasis starts rather fast, but it is still very annoying.

Once in a while after pressing delete the UI will freeze and take no input any more. One has to completely close the app and restart. Interestingly i observed, that after the restart of the app the delete operation most of the time was applied, so it is clearly a UI issue.

Cubasis scales badly with many clips i think. Paste operations are rather slow ( an iPad 9 is quite powerful hardware one will not see such bad performance in Cubase on the PC )

By the way: please , please add 1 or 2 zooming presets for the midi editor e.g. for 1, 2 and 4 bars. The constant resizing which mostly isn’t preserved when closing the midi editor is simply below the rest of the standard Cubasis has.
And having automation parameters only for the selected track would increase the usability by factors there. And obviously automation support for external AU well would make it more useful

I recently had 3 delete button UI freezes in a row. In a project with 1 (!) track and 2 audio recordings in it. If this is not reproducible then i frankly say that Cubasis isn’t tested enough internally. And from a more technical software perspective it would be possible to e.g. add a timeout to the command behind the delete button. Anything longer than 4s is probably more than suspicious. How logs etc. are then retrieved is another story. There are always different categories of issues, this one is in my view clearly a Level 1, because one can’t use the app if it happens. One has to re-do stuff in many cases and it costs several seconds to notice, re-start the app etc. Stability is more important than any new feature.

Hi @111378,

Thanks for your message.

If possible, please share the crash reports with me.

To do so, please upload them via Dropbox or similar and let me have the download link via private message (please make sure to add the full correspondence).


Just had Cubasis crash/freeze when erasing a clip, multiple times, different projects. When restarting Cubasis after a force close, the clip has been successfully erased, and the project(s) are thankfully not corrupted. Seems to happen in very complex projects, and too random to document. Cubasis 3.6, iPad Air 5, ios 17.2. This happened infrequently in earlier versions of Cubasis, and now again in 3.6. The worst bug I’ve encountered in an otherwise solid app.