CUBASIS 3.4.1 on iPad Pro M1 - Particular Audio Units failing to load properly

Fri 25th Feb 2022:

So in general I really appreciate Cubasis 3. It’s come on leaps and bounds and I take to it much better than the Cubase product (v9.5 I had on a PC), I want my problems to be music problems. If I just say ‘ASIO4ALL’ those in the know will understand!

The latest Cub3 version, I updated after a couple of days. It is 3.4.1 and it’s on my freshly-acquired (used) iPad Pro M1. It works really well, and two weeks ago it was all fine.

So, 3.4 was fine. It’s 3.4.1 that’s the first cause of this issue. Earlier versions, I had to make the ‘multi-core’ function turn off to stop crackling, and DSP rocketing up - now it’s the other way around I think, now I MUST enable multi-core. I put this down primarily to the new device I have, being M1 and seriously using multiple cores. My former device was iPad Pro 2.

But I did use Cub 3.4 on this M1 ipad just fine.

The fault is that iSEM synth by Oberheim was in a project. I loaded this 40-track project up, after updating to Cub3.4.1 and dabbled with a few synths, this being the first one. It made no sound when I played the track, there being some MIDI data already recorded.

I hit on the ‘iSEM’ icon to the left of the track, and a big empty rectangle appeared, where normally the image of the white fascia of the iSEM synth would be.

I went through all the other instruments - Moog, Micrologue, Hammerhead, everything else seemed to work, except Poison 202, another excellent instrument, and it wouldn’t load at first. I had a few tries at it, and it eventually did load. I turned solo off and on again, something like that.

So I returned to press on the iSEM synth issue. I copied the track altogether, and the big blank rectangle was still all that appeared when I tapped the synth icon, and even with ‘solo’ on, no sound came out.

I tried twice to ADD an entirely new track with iSEM in it - the first time, a failure, same blank rectangle, but the second times, success. So I copied the MIDI block to the ‘working’ iSEM track, and played around a bit, and then swiped the whole app away.

I gave it a minute, then re-invoked Cub3.4.1 but again, although the iSEM track appeared, the sound would not play and a blank space appeared when I tapped on the synth icon to the left of the track.

The troubling thing is the sporadic nature of it - this suggests to me, it’s a programming thing. A problem ought to be repeatable if the software is working well (you know whatI mean!).

But, I know nothing of these things. It stands out only because, Cubasis 3 has improved so much in terms of reliability, for me at least.

I know 40 tracks seems a lot, I sort of use it as a template type thing, I put my fave synths in, and have typical sounds use, selected on them. On iSEM, this is ‘Oxygene IV’ it so happens.

That brings me to another symptom - Audio Units are always insulated form one another, they never interact, unless like Fabfilter ProQ3 it’s intended to be aware of other instances in the same song project in that DAW.

What’s weird is that when you install a fresh instance of iSEM, it always comes up with ‘xtranasty’ as the sound patch. It’s like the intial patch.

Now, on Cubasis 3.4.1, that doesn’t happen - now it comes up with the ‘Oxygene IV’ patch. In fact, the blank rectangle is accompanied by a slow deliberate movement to the left, of the Audio Units list moving itself upward through the alphabetical list of AU’s, until it gets the (already highlighted) iSEM entry into view!

A bit spooky, but I assume it’s the Apple ‘learning’ thing, same as GarageBand makes two copies of files I save, because I demonstrated my habit of doing that to it I guess.

So, that may have nothing to do with the Audio Unit not loading problem, I don’t know.

The only other thing to mention is I have the 2Tb and therefore 16Gb memory verion of the iPad Pro M1. Not because I am rich, but because the UK government gave me back money that was mine in the first place, and because as soon as the energy price hikes were announced, the iPad Pro M1 I was looking at online, was made the same price as the 1Tb versions available used. It was a lot of money off, for just being 6 months old, put it that way.

I needed that money, because I realised immediately the first accessory was a necessity - a hub or dock. I’ll save other people the pain - get a Belkin F4U095, Express Dock HD, the one that works with Apple only. People use it for Mac Minis all the time. That’s why I took an interest. Between that and my Apogee Jam, and my irig MIDI2, I sort of have a cobbled-together Audio Interface without having bought one per se.

The F4U095 (zero 95) is a Thunderbolt 3 Dock/hub, which is why I took an interest because the BaseUs super-duper corner dinky type USB-C hub, is fine for general purpose use, but a dog for latency, in my view. Keyboard lag borderline too much, for me at least.

This solution works for me, the Belkin has an Anker USB3 7-port powered hub to it, and the Belkin itself has 170W power, it can deliver 100W to the device if needed. This is actually a better solution than lots of ports on the iPad, but it took me a while to appreciate that.

Sorry I digress, it’s been a long 3 weeks of research - I had no clue about hubs, Thunderbolt, etc.

Lastly, the only other pertinent fact, is that the iSEM Audio Unit, is on track 40 of 41 tracks. This again might not be relevant, but it’s right where you ‘swipe away’ an app, that little bar Apple have put there is fairly unobtrusive, but there’s a knack to it - and I always play a note on the synthmaster 2, every time I swipe the standalone synth, off-screen!

I am very happy with my new setup, and it was initially a toss-up whether to get a Mac Mini which would have been an M1 and actually less money and WOULD have had a handful of ports on it of course - in other words, the Mac Mini M1 would have been CHEAPER, AND had full-blown GarageBand and allowed for buying Logic Pro in future.

Yet, for me, there’s no contest in the end. The iPad route has been more expensive, but for me it’s better, and my only upgrade will be to that 15” iPad that Chinese rumours say there’s been tooling bought for. Once somebody much better-off than me has bought one and wants to sell it on of course.

so, I am still appreciating Cubasis, and maybe this is something to do with being almost the last AU loading on start-up (ie iSEM being 40 out of 41 tracks), but from what I have found and stated here, the state-saving of Cubasis is perhaps impinging on this.

It’s also possible, iSEM hasn’t been as well-written as it might be, and certainly Poison 202 synth has been around for ages, maybe a little bit of that is happening, older code, maybe a change in the AU spec - again I know nothing!

Take care, I appreciate how difficult these projects must be, nothing here will make me foul the 5-star rating I gave this mostly excellent DAW, I am all-in on the GB and Cub3 experience on Apple’s touchscreens, it generally has worked out for me in a way the big PC DAWs never did. That’s partly why I held fast to the iOS/iPadOS world, because actually every time I see Logic Pro, it gives me the heeby-jeebies. I need to be immersed in my music creation attempts, not fretting over routing and buses.

My very best, as we all dust off our metaphorical tin hats, keep calm and carry on. Start music not war, we could all agree.

Ian Richard Margetts aka richard getts on itunes etc.

Small addition problem - while trying to make new tracks with iSEM in them, the screen scrolling went all wrong.

Basically, unresponsive. I tried various different parts of the screen, and it responded better away from the middle of the screen area. Top right seemed better.

Also, a repeatable issue, is that once I put a brand new track in, with the iSEM AU selected afresh from the left hand side list of Audio Units, iSEM does load (with ‘Oxeygene’ patch like I mentioned above, not the default at all, but the patch my earlier iSEM has selected). BUT, once I swipe away, and fully then use the ‘swipe to middle of screen from the bottom’ method to remove the app from running, when I invoke Cubasis again, and it starts from scratch again, even this ‘fresh entry’ or track with iSEM synth, suddenly will display an empty rectangle instead of the synth, when I tap on the little synth icon.

A quirk, is that SOMETIMES, in the blank rectangle, a round pie-chart faintly appears, with a small picture of the iSEM synth, and behind it is clearly text saying ‘Audio Unit loading’. But the pie chart just keeps having this rotating radar-sweep going on, and never loads.

Earlier, it wouldn’t load, but said ‘Audio Unit Failed’. Not entirely repeatable then.

I will double-check, but I don’t have this screen-not-moving, this unresponsive thing, happen in GarageBand for example.

But there have been occasions when the screen was unresponsive, for no apparent reason, which I put down to iPadOS updating in the background (I am using the latest version as of Feb 22nd or so, 2022 - 15.3.1 is it?). It does that for a few days apparently, after an update, does some tasks over the first few days, finishing up.

That’s it, the sticky-screen unresponsive thing jsut happened, after I put another iSEM track in, makes me wonder if at around track numbers of 41 to 44, Cubasis maybe isn’t as happy as with a smaller number of tracks? I only say this in case you know of some technical reason that might make things difficult for tha app to keep running smoothly.

My best, as always,

IRM/rg

Hi @irm.money,

Thanks for your message.

Am I correct, that the Audio Unit loading problem is limited to loading iSEM?

Since iSEM has not been updated for about 2 years, we suggest to get in touch with Auria to let them know about the issue.

Thanks again
& stay safe,
Lars

Thank you Lars, I know you had to speed-read, and speed-type, and you meant Arturia not Auria…that’s a Freudian slip right there I think, though…don’t Auria make a DAW for iOS? No, I know they do, it’s created to like like an actual desktop DAW, which is why I use GB and Cubasis instead.\ even though Auria Pro was the first one I obtained…

My best, I’ll contact them at Arturia to let them know.
irm/rg

Hi @irm.money,

Thanks for contaction Arturia, please let us know about your results.

Best,
Lars