Cubasis 3 le iRig Pro Problem

IPad 12.9 v.2 running iOS 14.3

Cubasis 3LE + iRig Pro
I have an iRig Pro which is listed on your site as being a compatible hardware interface.
However Cubasis 3 does not see it despite trying all the tricks - plugging unplugging, restarting rebooting etc.
I am therefore unable to get out of demo mode.
Am I missing something? Is there a fault? Am I at fault and misunderstanding the process?
I would love to try this further than I am currently being allowed to.

Thanks for your time


Hi ridart,

Thanks for your message.

These are the steps to unlock Cubasis LE from demo mode:

  • Launch Cubasis LE 3
  • Connect a supported hardware
  • Wait for the unlock popup confirmation

In addition, please make sure Cubasis LE has access to the microphone.

Starting Cubasis the very first time, a popup asking your permission to use the microphone appears, which has to be accepted.
If you tapped “no” by accident, please change the setting manually as follws:

  • Please go to the iPad settings
  • There please go to Privacy / Microphone
  • Please make sure to enable Microphone use with Cubasis.

Does this help to solve the problem?

If the problem persists, please double check, that the device is powered efficiently, and make sure to use supported cables for connecting the audio device with the iPad etc.

Best wishes,

Thank you Lars,
I had been given that info on another iPad forum.
Of course it worked, so, user error but with proviso:

I would say that it’s not clear on the ‘splash screen’ that connection of the supported interface should happen at that point rather than before the app starts up.
My problem was that I kept quitting the app, making the connection and restarting, which is the normal sequence.


Paul ®

Hi ridart,

Thanks for your message.
We’re glad to read that the issue could be solved.

Normally, the Cubasis LE Demo Mode popup guides you through the procedure and clearly informs you about the required steps: “To unlock all Cubasis LE features, please connect a supported device…”

& stay safe,