Cubasis and AudioLayer undo button Mystery

Hello there guys .hope you are all doing well.
So today I was working on a project with Some instances of AudioLayer in Cubasis.
I tried to freeze one of the tracks so I could edit the Audio but Cubasis froze,so I had to relaunch the app.
When Cubasis restarted,my AudioLayer presets were missing.i started to reload the presets (Track 1 only).
At 0.47 second of the video you can see my playing the project without sound.i had track 1 and 6 on solo.
So I loaded some presets into Track 1 and only onto track 1.
Then I remove the solo button on all tracks and to my surprise, track 2 also loaded a preset.i hadn’t even touched the track.
At 1,47 seconds, I tapped on the Undo button, and strangely all my presets came back!!! :astonished:
Cubasis got raid of the preset I just loaded and automatically recalled the old presets I was working with before the App froze :open_mouth:
Please watch the video for better understanding.
https://youtu.be/DgkzN4pqCBg


Part 2

And also this evening,while working in Cubasis,I had D1 as an interapp adn some AudioLayer tracks.
I tried to freeze the D1 tracks to Audio.
It went fine till I tried editing the Audio and kaboom,Cubasis froze.:joy:
Luckily I’ve been taking snapshots of my projects before i freeze tracks in Cubasis lately.
Anyway ai had to restart Cubasis.Did so and the AudioLayer presets were gone missing .
I’m i the only facing this issue today ?:joy::joy:
Here is the video,since I’ve been trying to replicate another issue,I’ve been screen recording almost all my projectss

https://youtu.be/oaJwtuEEeaQ

Hi John,

I can confirm here Audio Layer Standalone App crashes on iPad Pro 11, iOS 12.1.1 without cubasis.

  • quit cubasis

  • launch Audio Layer Standalone App
    Result: crash everytime

  • shut down iPad Pro 11 and Restart

  • launch Audio Layer Standalone App
    Result: crash everytime

Looks like an Audio Layer Issue.

What iPad,iOS you are using.

best Jan