Cubasis and BS-16i Soundfont player

Just purchased Cubasis this weekend. What settings do you recommend in order to use the Soundfont player BS-16i multitimbrally in Cubasis? I find that after re-loading a song the bank numbers are messed up (the program number works). I’ve searched the forum but have not found much. I tried the followinh setup alternatives:

  1. Every MIDI track separately assigned to BS-16i as Audio Unit.
  2. First track assigned as a Inter-App, and because only one can be in use at a time, the other tracks are then assigned to “No instrument” but MIDI routing goes to the device “bs-16i”.

Both of the above will work, but when re-loading a song the wrong patch will be selected, because banks will be messed up (as far as I can tell, always defaulting to bank no. 1). This parameter is apparently not saved. Any help is greatly appreciated!

Hi Alessio,

Thanks for your message, and a warm welcome to the Cubasis family!

From what I know bs-16i comes with Audio Unit support.
Basically, Apple’s Audio Unit format offers overall much more flexibility and seems more stable as well, compared to Inter-App Audio.

Please give it a try to work with the Audio Unit plug-in versions of bs-16i, and let me know if this helps to solve the issues.


For what it’s worth I can get Bismarck working as an AU plug-in… but if I change the Soundfont from the AU interface it stops making sound.

If I try to load two instances it freezes everything.

Hi Lee,

Please make sure to report the issue to
Of course, we’re at hand to exchange with them about the issue, if required.


Thank you Lars for your reply. I’ve set up a new testing project with three Audio Unit BS-16i tracks that use different bank numbers (1, 2, 3) and program numbers (1, 2, 3). This works fine as long as the project is active, but after re-loading the project, the bank numbers are back to default (1, 1, 1) while the program numbers are restored correctly (1, 2, 3).

Is this an issue with Cubasis or BS-16i? I’ve also tried adding bank select messages (CC0) manually, but that didn’t help either.