Cubasis and Mikey Digital problem

I thought Mikey Digital would have no problem working with Cubasis 1.6. To my surprise, it doesn’t recognize Mikey
Digital at all. I’m running it on an iPad 2.

Am I doing something wrong? Any help would be appreciated.


Hi Jingleman,

When you open the routing tab on the audio track you want to record, what does Cubasis show you when you tap on the input field?

It gives the option to select a mono or stereo option. No matter which one I select, still no audio from Mikey.

Hi jingleman54,

We contacted Blue Microphones to solve this problem and we need more information:

  1.    Does the Mikey work on your iPad 2 when using other applications?
  2.   Are you plugging the microphone in before or after the software is initialized?

a. Sometimes when the software is already open and a Mikey is plugged in, the software doesn’t recognize the Mikey Digital. This is usually fixed by closing the application and reopening the application while the Mikey is plugged in.

Hi Jingleman,

We contacted Blue Microphones and they kindly tested the Mikey Digital with Cubasis and everything worked fine for them. They suspect that maybe you got a faulty unit or you have conflict with the OS. Please try restarting the app with the Mikey Digital already plugged in and if that does not work to fix the issue please make sure that your iOS is up to date. If that doesn’t work please contact Blue Microphones.