Cubasis Bug re Midi interfaces

I have recently bought Cubasis, and have found a major bug which I cant even imagine was let past testing for release.

If you connect a Camera connection kit to the iPad, and you have two devices of the same type, i.e. 2 x Roland Um-Ones or 2 x Korg SQ1s (doesnt matter as long as you have more than one of the SAME device connected) plugged into a USB hub which is then connected to the Camera kit, Cubasis displays them with the SAME!!! name (string) and when you select one it actually selects both (terrible pick list bug…using strings rather than indexes??). So, if you have two interfaces of the same type, with the same name, Cubasis wont assign them different names for example KorgSQ1-1 and KorgSQ1-2. It seems to select both (not good if you have separate midi data for each device). To test this guys, hook up two midi devices of the same type and manufacturer, and try and select just one of them…good luck!

Can I add that ModStep handles this perfectly, and displays all identical type interfaces with numbered string concatenations with the original name, it also then lets me select “either” not both.

Edit : Apologies I didn’t list some variables for reproduction of this bug.
Device = iPad Air 1
iOS ver = 9.3
Peripherals1 = Genuine Apple Camera Connection adapter.
Peripherals2 = Generic Usb2 10 port powered USB hub. (There are a few that don’t work as they draw too much power from the iOS device, most seem to work fine however)
Peripherals3 = Any TWO USB midi compliant devices, of the same type and manufacturer. Examples tested that cause this bug
2 x Roland Um-One usb midi adapters
2 x Korg SQ1 Midi to CV adapter/Seq
2 x Arturia MiniBrutes
(Its my guess that ANY 2 devices of the same type/manufacturer will cause this bug, not just the ones listed above however these configs above certainly do not work)

Bug/Error : When any of these two devices are hooked to the iOS device at the SAME time, you cannot select one or the other from a midi track in Cubasis, when you try to select one or the other, both devices get selected, also both devices share the same name so its impossible to tell which is which.


Has the camera connection kit ever allowed multiple controller inputs over usb hub, in ANY app???

I’m not even aware iOS allows any other use of multiple usb connections via USB-hub and camera connection kit.

I use quite a few apps, using a genuine camera connection kit, hooked to a fairly standard 10port powered USB hub, as long as the devices are Midi Compliant (no drivers required) iOS hooks them perfectly. I have at any one time over 10 devices hooked to the iOS device, using ModStep, this works…flawlessly! But, ModStep is the only app I have seen that handles multiple devices of the “same type and manufacturer”. ModStep was designed to be a central setup for a live midi rig. Genome, Cubasis, B-Step Sequencer all suffer from this problem. My only assumption is during testing, they never actually “tried” multiple midi devices of the exact same type (I must admit, it could easily be overlooked). I have spoken to the developer of B-Step, and he has confirmed it is a bug, and even said he only ever tested with a 1 x Roland Um-One and a few other synths, and has promised a fix in the next release.
I have been along time Cubase user for my post production, so I thought Id give Cubasis a shot as it was on special, assuming this issue wouldnt even be a concern for long time midi developers like Steinberg. But to my surprise, the devs missed this bug. Im a C++/ObjC dev and have seen bugs in picking lists like this before, when multiple strings of the same name are used as the datasource. The coders never assumed there would ever be “two” devices of the same name in the list, but this is certainly a possibility in this day and age with so many USB midi devices available. I can only assume (false) they are picking based on strings rather than index positions in the picker/View. I love Cubase and Cubasis looks great, but in a setup like mine, I literally cant use it now.

Google ModStep to see it in action using many midi devices on hubs.


You see me surprised that Modstep does this (I never tried).

So far I have never been able to use more than one source over camera connection kit with whatever I use. It would be fine to be able to do so: For example I would like to use controllers like Arturia’s Spark LE along with a Midi Keyboard at the same time.

So far I thought it was an iOS restriction, because I haven’t tried it with Modstep and never saw it working anywhere else. If iOS can handle it, it should be implemented as possible option in apps like Cubasis as well.

For sure. iOS is just a cut down version of Macosx. Most of the apis are the same, well, are getting that way, so iOS uses the same midi Api, other then the fact you cant “get” to the device list, (and adjust properties etc) without an app of some sort, it runs the same as osX. Cubasis is basically just querying the midi device list api call, showing me the list of devices, and letting me select one, but if there are two with identical names, it selects both, to me, thats a bug as it should only select one. If I want to select both devices I can just add another track and select that 2nd device.

It needs to be fixed as its only going to get worse as more people do this. Apple are “supporting” usb on iOS, it never used to be (supported as such), but, since iOS 9, they adjusted the power supply output, of the camera kit, to a really low amount (only a few mA), but most powered hubs (they MUST be powered in some way) work Ive found, they draw virtually no current. I have found one or two that dont work, it says they draw too much power, but they are all so cheap, bit of trial and testing but I now have a solid setup.

Hi thedood,

Thanks for your message.
Your bug report has been added to our backlog and will be evaluated by the team.


Lars, your a legend mate.
Look I have no idea for sure if what I said is the problem, but thats what it “appears” to be doing.
Once thats working Cubasis will be a great center controller for hardware.
Thankyou and Cheers

Just in case other readers are looking into using USB/hubs with extra gear on their USB iOS setups, heres a link to a fully supported apple device which lets you charge your iPad, is USB 3 compatible and also fully supports USB hubs. I have one of these in my setup with around 12 USB devices (2 x 8 port hubs) plugged into it at any point in time, all work perfect.