Cubasis Corrupting Project at Mixdown

Cubasis 1.9.7 on iOS 9.1 iPad Air 2 128GB

I created a project with 7 tracks (track 1 muted), with AUFX: SPACE as an InterApp Audio Send active on 2 guitar tracks and it plays back fine in the project. However,when I choose Mixdown (m4a or wav, with or without a range defined) I get 2 problems.

The first which has been present since the past few versions of Cubasis (and I have reported before) is more annoying than serious, where lots of apparently empty space is added to the end of the mixed down track, added several megabytes to the size of the file.

The second which I have only just encountered is much more serious!
As well as all the extra empty space at the end of the track, my guitar tracks are not starting in the correct place in the mixdown they are several bars late and it sounds terrible!

I tried exporting the project to Dropbox, rebooting my iPad, importing the project intyo Cubasis again via Audioshare and then the mixdown appeared to work. Until I realised I had no AUFX Reverb on the tracks. After shutting down Cubasis, starting AUFX: SPACE and then Cubasis, I got my reverb back and the track played fine in Cubasis but when I mixed down I got both problems back again!

I have tried rebooting my iPad, opening AUFX: Space and then Cubasis several times but still the problems appear at mixdown!

This is extremely frustrating and annoying. :angry: It is the final track of an album I want to release before Christmas!

Where can I send a copy of the Project file for you to test?


I think I may have found the cause of the track not playing back in the correct position.

I noticed that 2 different audioclips I had recorded had the same name (JamUp Pro (Output)(1)). After deleting one of the duplicates (which was fortunately fairly easy to reproduce playing wise) and re-recording it, I did another mixdown. I still got lots of extra silent space at the end of the file but at least the tracks played back in time!

What could allow 2 different audio clips to get the same name?
Can we PLEASE get the extra space at the end of tracks fixed? This has been an issue even on my old iPad2 iOS7 as well as my iPad Air 2 iOS 9.1 over several versions of Cubasis and rebooting does not solve it for me.