Cubasis for iPad

I have Cubasis 2 (vers. 2.7) on new iPad Pro 2018 (iOS 12.1.4) connected to the keyboard M-Audio 88 with iRig Midi 2
When I add tracks midi with instruments Inter-App, I hear, on every single track, all the sounds together with the instruments of all the tracks.
The solution is to close Cubasis and open again Cubasis to hear the single instrument added to a track
What’s the problem? Where am I wrong?
Thank you,

Hi Antonio,

Thanks for your message.

First thing to check is that “MIDI Input Only for Armed Track” has been checked under Setup/MIDI.

Then, Inter-App Audio instrument apps require a different MIDI setting, compared to Cubasis’ own or Audio Unit instruments (which do not require dedicated setups), when being triggered via external hardware.

In Cubasis 2.7, we’ve gave MIDI thru a refresh, allowing to re-route incoming MIDI to different channels for output to Core MIDI apps or hardware.
Please have a look at the “Inspector” chapter in the Cubasis in-app help to learn more.

Hope that helps!


Thank you Lars, I will try
Best regards,