Cubasis not recognising audio from external sources.

I have bought an iPad air specifically for making and recording music. I have bought cubasis and all the necessary connectors and leads to record audio (camera connection kit and berhinger UCA U222 as the audio interface). I’ve watched a man on YouTube record audio from guitars, keyboards etc with exactly the same set up yet when I plug it all in cubasis (or the iPad) doesn’t recognise it. In the settings it says no devise detected but I can hear the audio through the headphones so I know the interface is working. The microphone works and is enabled in the iPad/cubasis settings. Please help!!! It’s driving me mad! I have tried re starting the iPad and it makes no difference.

I’m having the same issue. I have a Focusrite Scarlett 18i6. I thought it was seeing the interface but it turns out the audio I’m hearing in my headphones is coming from the iPad internal mic. When I plug the interface in I get an error that says the USB device requires too much power. Are you seeing that as well?

No, it just does nothing. There’s no signal at all.


is this the video you are referring to:

could you give more information about your setup? iOS, Cubasis version etc.?


Try disabling the background audio in Cubasis settings then close and re-open Cubasis and see if that works and I assume you have assigned your inputs and outputs on each track and turned on the speaker icon on the tracks as well. If this works for you let me know, as the background audio seems to glitch and caused me a massive headache trying to sort it. Also I assume you have the audio interface in the CC (Class Compliant) setting (on interface itself).

Hi Riacardo, yes that is the video. I am using iOS 8.1.2 and the cubasis version is 1.8.3, the camera connection and the berhinger and that’s it!

Thanks Malmallen, I just tried disabling the background audio but no joy I’m afraid. The interface is very basic and has no settings on it.

I had a quick look at your interface and I may be wrong but is it compatible with the ipad air? It does not appear to state it on the spec on behringer site. I believe you saw some demo of this on youtube and to put you in the picture your problem sounds like a driver related issue (CC position on Steinberg UR44 interface - only for ipad use - a special driver).

I’ve looked at some of the video and noticed he is using an ipad with old type of dock connector you will have the new lightning connector (I assume) on the ipad air model which may be causing an issue.

It appears from behringer site that iOS (ipad op system) is not supported, probably best to contact them and ask the compatibility question with your ipad air.

many thanks, I will look into it

I had a similar issue with this yesterday, I am using behringer ua202, and it has been working fine for months. I have not tried using the interface since upgrade to ios 8.1.x until yesterday.

I could not get cubasis to get input from the UA202, but other apps (ToneStack) picked up the audio no problem.

After some messing about i tried loading audiobus, I then loaded cubasis as the output device and then suddenly everything started working fine. And now the audio is being picked up by cubasis again, even without loading audiobus first.

Seems wierd, but audiobus seems to have fixed something. No idea what though ?

I have the issue once again. This time I have been unable to get the audio signal nto cubase via anything other than the in-built mic.

This is now getting extremely frustrating.

I have tried 2 interfaces, Behringer UA202 and Realtone cable (rocksmith) from ubisoft.

I can get audio from Realtone into Tonestack, but not cubasis, I cannot get audio from UA202 into anythinbg anymore :confused: However audio output through UA202 seems to be working fine.

I wasted 3 hours trying to get this working so that I could play with my new iRig Blueboard, instead I was rebooting, starting things in different orders, all to no avail.

I very nearly deleted cubasis. Not entirely fair as just because cubasis is the hub for music making it gets the blame for issues that are not under it’s control.

There has been a recent update to audiobus, could this be to blame ? or could it be my fault for trying to use the realtone cable, and my iPad is now confused with audio input ?

Any help or ideas welcome

Hi all,

The Behringer website states the UA202 to be PC or Mac compatible only, same for the Focusrite Scarlett 18i6.

I’d suggest to get in touch with both manufacturers first (we’re able to support them with Cubasis versions if required) to have their say about iOS support.


There is definitely something software related causing this. I have been using cubasis on and off all day without trying audio input and have had no problems at all.
I have been loading and editing multiple projects without restarting cubasis or the iPad.
Tonight I plugged in the realtone cable and all seems to be working fine, audio input to cubasis and using tonestack as IAA insert. All working fine.
This is what causes the frustration, it workas perfectly most of the time, but at times it seems like nothing wants to work at all.
I don’t know where the problems arise from, whether it be iOS, Cubasis, IAA or one or more of the IAA generators/instruments or me but something is definitely causing issues that once they start seem to stay around for a while and then they seem to just go away and everything is ok again.
At the moment my suspicion is that one of the iAA apps is triggering the problems. Recently I have regularly been using iElectribe, Module, Galileo and iSem. I have suffered problems with iElectribe not responding to MIDI, and then when it does te audio is broken up. This too is working fine at the moment.
I will keep going, and try and spot a pattern as to when issues occur to see if I can find certain combinatioons that are problematic.
Thanks all for listening to my rants and ramblings.

Just to confirm, I have a similar issue.

I’ve got the latest iOS and Cubasis on an Air 2 with a Focusrite 18i20. I sometimes have no audio output, although Cubasis is seeing the interface. This is something that didn’t happen for me in the previous version to Cubasis 1.9

When this issues occurs I haven’t tried the audio inputs, so can’t confirm the same issue. Although it is probably reasonable to suggest that if my output isn’t working, then maybe the inputs aren’t either.

While I understand the obvious frustration of others having similar issues. In my case, a simple restart of Cubasis sorts out the issue.

Hi David,

I gave Focusrite’s OS Compatibilty Checker a short check, iOS compatibility is not stated there:

Please get back to Focusrite about the issue.



Hi Lars.

I don’t think that compatibility checker that you reference to is for iOS compatibility. I have a feeling that it only gives results for desktop operations systems, and none of the portable ones such as iOS, android etc. As other devices in the lists, that are supported on iOS, do not show up either.

Plus here is a statement from the focusrite site that clearly states iOS compatibility.
Scarlett 18i20 | Focusrite › products › USB Audio Interfaces
18i20 supports both Macintosh and Windows computers as well as the iPad … Suitable for Windows, Macintosh and even iOS platforms, Scarlett 18i20’s USB 2.0 …

Plus, I had no problems before the last Cubasis update. Even now, as well as before, if the interface isn’t ios compatible as you are suggesting, and by extension not Cubasis compatible. Why does it work 99 percent of the time? Why does Cubasis see all the possible routing? Why am I able to use 8 simultaneous inputs? Why does the iPad see it as an input and output option? And why was everything fine before updating to Cubasis 1.9


Hi Dave,

As stated before please get in touch with Focusrite about the issue.
We’ll gladly support them with promo codes if required.

No changes took place in that area with 1.9.


Hi Lars.

While I appreciate that there where no designed changes in this area with regard the introduction of 1.9 This does not mean that a bug hasn’t slipped through.

I’ve noticed that you’ve recommend using the Focusrite OS compatibility checker to others as well as myself. Are you sure that this checker is designed to show compatibility with iOS. Like I said earlier, other Focusrite devices that are compatible with iOS, do not show up either.

It could be the case that you are recommending Cubasis users to use an incorrect checking tool.


Hi Dave,

It might be possible that the list seems not to be up to date (I can’t answer that).

Nevertheless please get in touch with Focusrite, since they are the manufacturers of the device(s) and should be able to give a well-founded answer.


Hi Lars.

I’ve now had confirmation from Focusrite support that the OS checker is not designed to show compatibility with iOS, it is only for indicating compatibility with the various versions of Mac and Windows operating systems.

They also confirmed that the 18i20 is fully iOS compatible.

Given that the issue is not due to iOS compatibility for the 18i20. Is it possible for Steinberg to look into the audio issue that I’ve described since upgrading to Cubasis 1.9