Cubasis on Ipad Pro 11 (3rd Generation with M1 processor)

I am unable to get Cubasis running in a stable way on the new Ipad 11 with M1. Playing and recording of a single track is ok. However, when configuring three midi tracks in parallel with SWAM trumpet, Ifretless Bass and Ravenscroft piano, all sound outputs get mute after a minute. Also the speed doubles sometimes when playing a track. Even the sound apps itselves do not play sounds
With Garageband I had no problem to play and record all three instruments.

The only way to solve the silence is to shutdown and restart the Ipad.

Any idea what could get wrong or I missed to consider? Thanks!!!

Hi @Achim_Siegert-Wilcke,

Thank you for your message and welcome to the Cubasis forum!
Also thank you for sharing your feedback with us, using Cubasis with the iPad Pro M1.

In our testings, Cubasis runs fine on iPad Pro 11.

Therefore It would be helpful for us to know, if the problems are related to Cubasis, the assigned 3rd party instruments and/or the associated settings. In addition, please let us know if you have additional audio hardware in use (e.g. an audio interface, established Bluetooth connections etc.)

(1) Please follow the steps below to reset Cubasis and the iPad, and let me know about the performance results, when using Cubasis on its own.

(2) Once done, please check if adding AU instruments (piece by piece) lead to the issues described above.

(3) In addition, please let us have screenshots that show your chosen Cubasis project and latency settings, and give it a try to set Audio Engine Latency to OFF.

Even the sound apps itselves do not play sounds

Please let us have more details, which sound apps do not play.

Please let us know about your results.

Thanks
& best wishes,
Lars

Cubasis and iPad Reset Instructions

  • Please load an empty project
  • Close all running apps, including Cubasis
  • Fully shut down the iPad

Thanks for your immediate reply!

I loaded an empty project, closed all running apps, shut down the iPad and restarted Cubasis.
I added a midi track, selected inter-app and selected ravenscroft piano app.
Screnn switched to ravenscroft, I saw the cubasis buttons on the top, switched back to Cubasis and recorded some notes.
Result: midi has been recorded, but no sound output.
So ,back to square one, same procedure, opended Cubasis, added a midi track and started recording with internal piano.
Result: speed and of sound and recording is reduced by ca 50%, even though the bpm has been unchanged.
So, back to square one, same procedure, opened Cubasis, generated a new project.
Result: I got a warning, that sample rate has been set to 16.0 kHz because either the hardware does not support my initial setting or another app is blocking it.
I went to settings and saw:

  • sample rate is 44,1 (can‘t be changed)
  • bit resolution is 16
  • device latency is 8
  • audio engine latency is 64

Any idea?

Thanks Achim

Additional remark: tested the identical setup with Cubasis 2 and had no problems!!! So it seems that none of the external audio apps is the cause neither the Ipad Pro 11 with M1 but version Cubasis 3.3.

Thanks in advance for your support!

Hi @Achim_Siegert-Wilcke,

You’ve mentioned that “sample rate is 44,1 (can‘t be changed)“, which leads to the assumption that probably a Bluetooth hardware is in use (given the 16.0 kHz rate) and the fact, that native iPad Pro sample rate is set to 48 kHz.

Important:
Please provide us with further information, what audio hardware is in use with the iPad.

Here are some further recommendations:

  • Please try again without using a (Bluetooth) audio hardware (Bluetooth). Important Note: Please let us know what hardware is in use?
  • Please set Audio Engine Latency to OFF
  • When using Bluetooth hardware, enable „Bluetooth / AirPlay” under Setup / Audio (see below for more details)
  • Our engineering tried the steps with Ravenscroft as Inter-App Audio (IAA) instrument which worked flawlessly on the iPad Pro 11” 3rd gen (M1 CPU, 2021).

Please let us know about your results!

Thanks
Lars

How to connect a bluetooth audio device with Cubasis 3

Please use the following steps to connect your Bluetooth audio device with Cubasis 3:

  • Please connect your Bluetooth audio device to the iPad
  • Launch Cubasis and go to Setup/Audio and enable “Bluetooth / AirPlay” by tapping the corresponding button

If required, please go to Setup/Project and choose (or reselect) the matching sample rate of your project.

Hi there!
Seems that the bluetooth tool was the root cause of my problems.
As devised I activated Bluetooth/Airplay and it worked, sample rate can be set to 48 kHz again. My bluetooth device is an Airpod Pro. Suprisingly this wasn‘t an issue with Cubasis 2. However, thanks for your support!

Best regards Achim

Hi @Achim_Siegert-Wilcke,

Thanks for the update, glad to hear that the issue has been solved.

Best,
Lars