Cubasis Sample rate

On new iPad Pro M1 (5th gen) both class compliant Apogee Mic 96 or Sennheiser MK4 Digital are not recognized even if powered.
In addition it is not possibile to change/rise project sample rate (fixed by default @ 48khz).
Take notice that the units are fully recognized at 96k/24 bit by Garageband and Apogee Metarecorder apps.
The iPad and the USB mic are connected/powered through a Satechi USB C Dock with USB A data transfer port , mini jack audio out, Hdmi 60hz port plus cards reader slot.
Cubasis 3 is @ last version available.
Thanks in advance for support.
Best regards, MV

Hi @Marco_Vierucci,

Thanks for your message and a warm welcome to the Cubasis forum!

Starting Cubasis the very first time, a popup asking your permission to use the microphone appears, which has to be accepted.

If you tapped “no” by accident, please change the setting manually as follws:

  • Please go to the iPad settings
  • There please go to Privacy / Microphone
  • Please make sure to enable Microphone use with Cubasis.

Once done, please follow the steps shown here to route the audio channel in Cubasis accordingly: Getting Started with Cubasis | This Is What You Can Do with Cubasis - YouTube

If the problem persists, please check to use the Apogee and Sennheiser mics without using the USB C dock.

Please let me know if this helps!

Stay well,

Dear, the settings are ok, microphone enabled for Cubasis app.
Unfortunately seems like CB app decide to low the output settings to the lower audio interface connected.
In this case maybe the dock mini jack output.
This issue does not show up when other apps as Apogee Meta Recorder are used.
Meta Recorder recognizes Mic, Mk4, Jam as 96/24 units and the mini jack out works perfectly.
Can You please check and suggest a way to solve this on Cubasis? I do love your app, i’m sure it’s the top DAw for IOS.

Seems to be solved thanks to a M-Audio Air Hub M-Audio
I can connect USB microphones without significant latency issues, Cubasis works @ 96/24 plus i have both monitors and headphones outputs.

Hi @Marco_Vierucci,

Thanks for your updated message.
We’re glad to read that you’ve been able to resolve your issue yourself!

Enjoy making music
& stay safe,