Cues stave hash

I can move these by hand… but what is the way I should be dealing with this?
Adding cues has collided the staves.

I’d need to see more of the context to know why Dorico has done that. I can only imagine that you must have forced Dorico’s hand in the layout in some way, e.g. fixing the number of systems per frame somehow, either via Layout Options or via breaks. If Dorico has a free hand to adjust the layout then it will eliminate these collisions on its own.

I don’t think I’ve forced anything? (Although it will probably turn out I have…)
In any case the collision is vertical, with plenty of space available.
I’ve attached it.
Worthy is the Lamb that was Slain Brass Octet copy.dorico.zip (395 KB)

Daniel, the cues popover is just brilliant! I’ve moved from ‘if I have to put one in’ to massive, cheesy overuse!

Ah, of course: it’s because the Trumpet 1 staff doesn’t have any rests, for some reason. At the moment, Dorico doesn’t prevent things from colliding with completely empty staves, which is something we need to look at. So you will indeed need to sort these collisions out for yourself in the short term. I’m glad you like the cues feature, though. We really do feel it’s a game-changer for part preparation.

Hi Daniel,

I’ve forced some rests (although I don’t understand why a forced semibreve rest is coming out as two minims…?).
The trumpet slur has uncollided.
But the Euphonium/Trombone staves are still on top of each other as attached.
?

Thanks!

Steve, It looks as if the trombone and euphonium staves are colliding. I would have a look at Layout Options, Vertical Spacing, Staff to staff, and set this to 8 spaces, click Apply and Close. I think it will fix this issue and give you the filled out page you desire.

Steve, I’ve noticed also that you may want to go to Layout Options, Players, Bar Rests and Multi-bar Rests and click on “Show rests in empty bars”, click Apply and Close. This will give you bar rests.

“I’ve forced some rests (although I don’t understand why a forced semibreve rest is coming out as two minims…?).”

Perhaps I can help but need more information on where this is occurring.

For this kind of thing, I prefer not having the whole bar rests.

Daniel, you may want to look at this - it seems strange to me… (attached movie below)

Steve, I see extra rests in the cue of the Trumpet 2 part that is showing in the Trombone in measure 30. I made a little quicktime movie. (The original source from Trumpet 2 does not have the quarter and half rests!)

Is this because you added explicit rests to the Trombone part? You won’t need to do that because by doing so you’ve duplicated rests.

https://www.dropbox.com/s/q8qjwomhjl7qdlm/cue%20extra%20rests.mov?dl=0

I’ve not forced any rests anywhere apart from bars 31 and 32 as detailed above.

Also, if I delete the cue in bars 29/30, the trombone notes stem direction doesn’t revert to down.

I still think there is something wrong going on, but Daniel will need to chime in. The trumpet cue should not pad out the remainder of the measure with rests after the ending point of the cue, and it is doing that. But if you need to you could always force the stem down on the trombone part. Turning on voice colors shows what is happening with the extra rests of the cue.

Did Vertical Spacing help solve the colliding stave issue?
Screen Shot 2018-02-03 at 11.12.58 AM.png

It’s easy enough to fix the stem and the collision, but I’d like to know why it’s happening and if I’m doing something wrong. Cues haven’t caused this anywhere else.
Vertical spacing solves it, yes, but also changes every other system.
Thanks for your help!

Musicmaven and Daniel,
Sorry, should have been more specific…
Vertical spacing stops the collisions, but the Euphoria and Trombone staves are still weirdly close together.