Custom expression map creating random CC1/CC11 values with every note?

I’m learning to build custom expression maps for some of my Kontakt instruments, and ran into a weird issue for which I’m guessing there is some preference or setting somewhere…

Basically I have a violin and tested with basic quarter notes. However, when playing back, I’m noticing each note jumps around slightly in volume and dynamics. Yet I am marked with one dynamic mf. The passage looks like this:

I checked the VSTi and I can see its sliders for Dynamics (CC1) and Expression (CC11) moving up and down with every note, which is not what I want.

I am using volume and secondary dynamics both on CC1 and CC11:

It’s kind of hard to see but the dynamics lane in the key editor is completely static, whereas CC1 and CC11 are stepping slightly up and down with every note hence my issue:

I’m guessing this is some kind of humanization attempt by Dorico? In any case it sounds less natural with this instrument and I’d like to turn that off, but I checked around in the playback options menu and couldn’t find anything related to this.

I did discover this option has some effect, when set to 100% it definitely amplifies the effect in the wrong direction, so one would think 0% removes it entirely, however set to 0% the issue is still there.

Happy to share the project file if that helps, just not sure if it’s useful to look at unless you have the instrument installed…

It could be the default playback dynamic options. To change them go to Library>Playback options>Dynamics. There are a number of dynamic settings which influence velocity or in your case CC11 and CC1. You can untag all and or put them to 0 if you do not want them.

Thank you. I did some poking around. I found there were two settings which flattened the CC1/CC11 lines. If Dynamic Curve power is set to 0, or all beat stress is set to 0:

However, part of the issue here is this specific library (soft string textures) is very sensitive which is why I’m hearing a noticeable difference when every note is turned up or down. When combining with other libraries I will not likely want to flat line all dynamics globally. So I reset the playback options and went back to my expression map to adjust playback overrides:

Unfortunately, none of these work. My guess is because it is “increase dynamic by…” from the global playback settings. There’s no option to decrease by, or set those values in a negative direction.

I did, however, discover that the playback option override above which says “dynamic curve power” when set to 0, appears to fix the issue for this articulation. I think this might be my best bet, I would rather address dynamics from there manually on this one patch, than affect all other instruments globally.

If you library is very sensitive you can also experiment with maximum and minimum level and with the dynamic curve power.

Another option to tune and balance your instrument might be in the library interface . For example in BBCSO I deactivated the global setting for microphones to allow changing mike levels for each articulation individually. I reduced the level for short articulations significantly and longs a little bit to better match legato phrases. for some classical pieces . This is faster than manually adapting CC1 and CC11 or velocity for individual notes.

1 Like

Ok thank you, that’s good advice!