Cut/delete time - but not pedal/sustain markings in MIDI

I’m running into an issue where I’m trying to cut out little parts of a MIDI track (the parts where I messed up during recording) but when I do so (using the range selection tool and then doing “cut time” or “delete time”) it seems to be messing up my pedal markings in the MIDI track for the content after the cut. It seems to be cutting out the notes but not the pedal indications in the MIDI file–even though I’m doing the range selection & cutting time directly in the MIDI track on the timeline. I looked to see whether I could do the cut time function in the Score Editor (thinking that since that’s where you can see the pedal markings, it may grab the pedal parts that way) but it doesn’t seem like cutting time is an option in the Score Editor. Any ideas? Thanks.

Hi and welcome to the forum,

It works as specified. It deletes/cut only the time of the part, you select. If you want toCut/Delete also any CCs, you have to select them by the Range Tool too.

Thanks, Martin. I don’t know if I know how to also select CCs using the Range Tool. I did just discover the In-Place Editor, which is allowing me to also select CCs. But oddly, when I do Cut Time in the In-Place Editor, it cuts the MIDI part in two and I keep needing to go back and glue them back together. Do you know if there’s a way to avoid that? Thanks again for your response.


Just extend the range also down over the Controller lane, please.