Cycle MIDI "stacked" mode not working when record in editor is on

Hello, thanks in advance for any help on this! So I heavily rely on the Cycle Midi mode “stacked” because what I like to do is set the loop cycle to 8 bars, and just start coming up with different riffs, and then afterwards, choosing the best lane. I have the following settings:

Linear & Cycled MIDI Recordings: New Parts

Cycled MIDI Recordings Only: Stacked

I like this settings because it saves everything I play into lanes and I don’t hear the previous cycle. But the issue is, when I have “record in editor” enabled, it breaks these settings. As a matter of fact, it doesn’t create lanes at all, and just combines every take into one.

The reason why I have to turn on record in editor, is because I rely heavily on the scale assistant to automatically snap live input into the correct scales for me. Can I utilize that and keep my cycle midi recording settings the way I want them?