cycling samples round robin in halion, problem solved??

i recorded some tuned feedbackloops with my re201 into a cubase audiotrack. cut up 3 different part and dragged them into the mapping screen of halion 6, overlapping each other, thinking id be able to roundrobin play them to get slight variations.

the samples are mapped out on top of each other now and when play they all sound simultaneously…
the samples are set to variation group 1,2,3 respectively and in the program , variations groups 1,2,3 are set to round robin yet still they all play on top of each other.

having dragged only 2 samples into halion i experienced som glitchy behaviour in the way that at first they played on top of each other but when i turned the variations groups off and then on again it suddenly worked they way i (and every other person with common sense) was expecting - with the samples playing roundrobined.
but as i added the third sample that sample played all the time together with the other two samples alternating each other.
remembering id had some glitchy behaviour i then removed all samples and mapped them all before even starting fiddling with the variation groups hoping that id somehow unglitch the glitchiness but with no success and after 45 mins im still stuck with 3 samples of tuned feedbackloops playing on top of each other.
juicy no doubt but its not what i want, being a one oscillator kind of person.

thankful for any suggestions on this which seems to be either me having a mental malfunction or an erratic behavoir of halion

Hi BeckettColt,
you have to set the variation group for all three loops to the same value ( e.g. variation groug = 1), then go to the “Sound” tab and enable the Variation Group for the corresponding program or layer. Set the “Mode” for variation group “No” 1 to “Round Robin” and that’s it.

best regards