D 4 activation manager not working

I re-downloaded sam and when I try to open it, it opens then disappears. I get the box with the relaunch button but it doesn’t do anything. Have to say, I followed the directions, entered the download access code, entered the e-licenser activation code, D 4 worked so I don’t understand t]why there was an extra step, or at least a pop-up reminder to complete that final step.

Richard, in your case, your Dorico 4 license is permanently activated (it looks like you have only just managed to do that today). You should find that running Dorico 4 is sufficient to get the license refreshed.

When I try to open a Dorico project the sam opens but just sits there, and hitting relaunch does nothing, so Dorico still does not open. This is what I see when I open the License Control Manager:

That’s OK: at this stage, eLicenser Control Center is irrelevant because it plays no part in whether or not Dorico 4 runs.

However, you do need to run Steinberg Activation Manager. Can you please try restarting your computer, and then running Steinberg Activation Manager before you run other applications?

Did as you asked and sam opened showing D4, but trial expired and am not sure what to do next.

Happy to say that after repeating the above process several times it is now working again. I realize that Daniel has put a lot of time into this and appreciate that, thanks.

1 Like

I went through all the posted steps in your link and nothing. I have opened a support ticket. Daniel, may I make a suggestion to simplify everything. Those of us that purchased 3.5 and the upgrade to 4, give us a coupon to purchase for free a new complete version of 4, therefore generating a brand new license already integrated into the new system. I am willing to make a complete re-installation of version 4.

this sounds as though it is the same issue i am having… see my post

i have also listed the log files which show errors generated upon running the activation manager, which is also hanging for me ( see below). so i guess it’s not something i did to step on my own feet.
i guess i have two choices till i get this fixed.

  1. use 3.5
  2. spend the weekend reading Adler on orchestration ( better time spent)
    :

activation manager log

2-02-11 21:09:08 -05:00] [error] NNSocket: ERROR: 138: Timed out nn_send
[2022-02-11 21:09:08 -05:00] [error] ERROR: Error connecting to License Engine: nn_send
[2022-02-11 21:10:06 -05:00] [info] ====== Steinberg Activation Manager terminating
[2022-02-11 21:10:06 -05:00] [warning] qrc:/HomePageForm.ui.qml:131: TypeError: Cannot read property ‘initialLicenseStatesLoadDone’ of null
[2022-02-11 21:10:06 -05:00] [warning] qrc:/HomePageForm.ui.qml:39: TypeError: Cannot read property ‘licenseStatesRowCount’ of null

Bernhard, have you tried quitting SAM, opening Activity Monitor (Mac) or Task Manager (Windows) and killing the Steinberg License Engine process, then starting SAM again? I think the problem on your system could be a stale Steinberg License Engine process.

I actually don’t see it running; but in any case, I did do a reboot which should have cleared anything. Furthermore, when the AM runs it says the engine is not running and attempts to launch it (see my log below or in my prior post). i also restored the prior version of the activity manager to a restore folder (1.01.477) ( current vsn is 1.01.478) and that made no difference.

AM log

2022-02-12 17:11:12 -05:00] [info] ====== Steinberg Activation Manager 1.0.0.477 starting
[2022-02-12 17:11:12 -05:00] [info] Mediator: initialising QML
[2022-02-12 17:11:12 -05:00] [info] Mediator: initialising QML – done
[2022-02-12 17:11:19 -05:00] [warning] Both point size and pixel size set. Using pixel size.
[2022-02-12 17:11:20 -05:00] [debug] component completed
[2022-02-12 17:11:20 -05:00] [info] Mediator: postUIInitialise()
[2022-02-12 17:11:20 -05:00] [info] Mediator: initialising SILK
[2022-02-12 17:11:20 -05:00] [info] License Engine isn’t running. Launching
[2022-02-12 17:11:21 -05:00] [info] Sending ping to SILK service
[2022-02-12 17:11:31 -05:00] [error] NNSocket: ERROR: 138: Timed out nn_send
[2022-02-12 17:11:32 -05:00] [info] License Engine isn’t running. Launching
[2022-02-12 17:11:32 -05:00] [info] Sending ping to SILK service
[2022-02-12 17:11:42 -05:00] [error] NNSocket: ERROR: 138: Timed out nn_send
[2022-02-12 17:11:42 -05:00] [error] ERROR: Error connecting to License Engine: nn_send

or?.. maybe the engine is failing to start. how do i start it manually; that is, on windows, where is the exe for the engine? if i can start it manually and it fails, i may be able to get better information about what is going on.

also. i have the UR242 Audio interface which uses the dsmMixFX software which uses the license manager and that software works fine.

No, dspMixFX doesn’t use Steinberg Activation Manager. The only product that currently uses the new Steinberg Licensing system is Dorico 4 (and, indirectly, HALion Sonic SE 3.5, which is included with Dorico 4).

Could you please zip up the whole Activation Manager folder from /Users/your-username/Library/Application Support/Steinberg and attach it here? Although I can’t personally parse out all of the logs expertly, I can ask my colleagues to take a look as soon as they’re able.

Just spent a fruitless hour and a half following the instructions in the pinned thread – several times.
No joy: eLCC seems to get into a loop.
Have written to Support.
I followed all the installation and activation instructions when I purchased Dorico 4.

And this is supposed to be better than the dongle? :smiley:
David

Some issues:
The firewall should be open for all Steinberg products.
Your Browser has to be able to open all necessary windows for signing in and to open the activation manager.
Try deactivation of all your browser add-ons.
Forget all measures you have taken for data protection.
Kill all running background processes of Steinberg software.
Then you “might” have a chance to activate Dorico 4.

Something else: It seems to me that finally Dorico no longer runs with Windows 7. When I try to start it, I get a message that some .dll connection can not be started: “Der Prozedureinsprungspunkt “CreateDXGIFactory2” wurde in der DLL “dxgi.dll” nicht gefunden.”

Is it possible to run Dorico on Windows 10 totally offline? If not, I will leave at this point…

It is possible to run Dorico 4 completely offline once you have activated it via Steinberg Activation Manager, yes.

I have the same problem. I purchased Dorico 4, had some troubles with activating it. Support send a new DAC which worked and seemed to activate properly – it showed as “Activated”. Now (maybe 30 days later) it shows “Verification Pending / Expired.” (and my v3.5 license is no longer upgradeable in the eLicenser). The DAC code will generate an activation code, but of course the eLicenser doesn’t have a license to upgrade, so it stops there. I’ve tried all the steps outlined in the guide Daniel put together, to do avail. What should I try next?

(I’m loving D4, but licensing issues are frustrating.

Sorry for the inconvenience caused, Dennis. Your case looks a bit unusual to me: I’m in contact with my colleagues in the Steinberg Licensing team and will come back to you as soon as I can.

After installing the new Activation Manager -Version 1.1,
I have a problem.
When I go offline and start Dorico 4.01, it says “No Licence”.
I have to go online to activate D4 again.
I tried this several times.

After Re-Installing the previous Version of SAM
all is fine. I can run Dorico offline without problems.

The most recent version of the Activation Manager is 1.2.0 (released yesterday) - have you tried using that?

1 Like