D4.1: Key editor tempo editing can get stuck

First - again a wonderful update - thanks so much to you folks. I’ve said it before and I’ll say it again, but while I will welcome every new Dorico release this is wrapping up the feature set I need to get my work done.

In testing I’ve got the Key Editor/Tempo editor stuck in that mode. I happened after I changed the scaling in the edior using the -+ slider. I have a memory this kind of thing happened before? Anyhow, maybe there’s something I’m misunderstanding how 4.1 is supposed to work, and while I wonder if Daniel listened to me about editing the tempo usability, somehow I don’t think this is the response :grin:

Here’s a vid showing the stuck tempo editor, I can’t find a way to get back to the CC editors

Can be fixed by quitting and reloading, and yeah it’s easy to reproduce, just go into the tempo editor and fiddle the -+ zoom slider.

You don’t need to quit and restart. Switch to Play mode, choose another track from the track overview, then switch back to Write mode, and you should be able to re-enable linked mode, if it’s not already been re-enabled.

Thanks Daniel - just checking, it is a bug or a feature? Thinking about it this is a pretty neat solution to my whining about the tempo editor, once in tempo you stay there, just switch modes to get out. So if it was unintentional I’d call it a feature and encourage you to keep it :grin:

1 Like

It’s not a bug, inasmuch as it’s expected that the link button doesn’t appear when you have the tempo track active, but it’s also not very helpful, as we’ve discussed since Dorico 4.0.30 appeared. We do anticipate making some changes to make it easier to change the target for the lower zone editor in due course.

1 Like